Jetson nano does not boot with my current microSD card

My jetson nano doesn’t boot properly. specifically, it displays the Nvidia logo and then proceeds to boot with these log messages being the last thing displayed before the screen goes blank.

I have another Jetson Nano device, so I tried using its sd card and now it works. I’m guessing the issue is in the first MicroSD card but I’m unable to read its data from a personal computer. the data in there is important so I would appreciate any advice on how to solve this issue.


as you are able to boot the device with another SD card, sounds like the bootloader is still working fine.

What do you mean with I’m unable to read its data from a personal computer.?
Like, you only have a Windows PC, and it’s unable to read/write ext4 partitions?

You may first try if you can still login and dump log via UART.

Thanks for the response,
I used a Windows PC and it doesn’t allow me to read it normally. Maybe there is a way to read it that I’m unaware of. Also when you suggested I log in and dump the log via UART can you clarify? because from my point of view, the jetson nano gives a blank screen. But maybe there is a way to login by cli?

There are some tools on Windows that allow you to read/write ext partitions.

Yes, and please follow this guide to setup UART and see if you can login:

FYI, Windows does not normally understand an ext4 partition. Use Linux. One of the tools on Windows is WSL2, but what that really is is a Linux VM. To really know what is going on with the SD card you’d likely want to use a Linux PC, monitor logs with “dmesg --follow”, and then insert the SD card. The log lines occurring from the plug-in would be a good start.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.