Jetson Nano doesnot boot while using debug port as UART

Hi team,
We are using Jetson Nano Production Module in which we have utilized debug port i.e. ttyS0 as UART with baudrate of 38400.
We have modified /boot/extlinux/extlinux.conf file to disable debug port.

We have a peripheral which is based on 38400 baudrate. If we change the baudrate of peripheral at 9600, it will work fine. But at 38400 baudrate Jetson will not boot up.
If Jetson boots up first and then the peripheral is connected, then the setup works fine, but when Jetson and peripheral both are powered on at same time, Jetson Nano will not boot up.

Please suggest some solution for disabling the debug port appropriately or a way to boot jetson nano while the peripheral is connected.

hello vivek_rawal,

please follow below steps.

  1. Remove “earlyprintk=uart8250-32bit,0x70006000” from kernel cmdline
  2. Change ODMDATA to 0x14000
  3. Remove console=ttyS0 in kernel cmdline.
TIMEOUT 30
DEFAULT primary

MENU TITLE L4T boot options

LABEL primary
      MENU LABEL primary kernel
      LINUX /boot/Image
      INITRD /boot/initrd
      # APPEND ${cbootargs} quiet root=/dev/mmcblk0p1 rw rootwait rootfstype=ext4 console=ttyS0,115200n8 console=tty0 fbcon=map:0 net.ifnames=0 sdhci_tegra.en_boot_part_access=1
      APPEND tegraid=21.1.2.0.0 ddr_die=4096M@2048M section=512M memtype=0 vpr_resize usb_port_owner_info=0 lane_owner_info=0 emc_max_dvfs=0 touch_id=0@63 video=tegrafb no_console_suspend=1 debug_uartport=lsport,4 maxcpus=4 usbcore.old_scheme_first=1 lp0_vec=0x1000@0xff780000 core_edp_mv=1125 core_edp_ma=4000 gpt tegra_fbmem=0x800000@0x92cb4000 is_hdmi_initialised=1  earlycon=uart8250,mmio32,0x70006000  root=/dev/mmcblk0p1 rw rootwait rootfstype=ext4 console=tty0 fbcon=map:0 net.ifnames=0 sdhci_tegra.en_boot_part_access=1 quiet root=/dev/mmcblk0p1 rw rootwait rootfstype=ext4 console=tty0 fbcon=map:0 net.ifnames=0 sdhci_tegra.en_boot_part_access=1

# When testing a custom kernel, it is recommended that you create a backup of
# the original kernel and add a new entry to this file so that the device can
# fallback to the original kernel. To do this:
#
# 1, Make a backup of the original kernel
#      sudo cp /boot/Image /boot/Image.backup
#
# 2, Copy your custom kernel into /boot/Image
#
# 3, Uncomment below menu setting lines for the original kernel
#
# 4, Reboot

# LABEL backup
#    MENU LABEL backup kernel
#    LINUX /boot/Image.backup
#    INITRD /boot/initrd
#    APPEND ${cbootargs}

I have removed “earlyprintk=uart8250-32bit,0x70006000” and console=ttyS0 from the /boot/extlinux/extlinux file but still the issue is same.
I have shared the file, can you please suggest the modifications in that file

hello vivek_rawal,

had you change ODMDATA to 0x14000 and re-flash the target?

hi JerryChang,
Can you please provide guide to change ODMDATA

I’m moving this topic to correct platform category → Jetson Nano.

1 Like

hello vivek_rawal,

there’s ODMDATA definition, as you can see in board configuration file, i.e. p3448-0000.conf.common