Jetson nano emmc flash script hangs while flashing

We have a custom built carrier board where we have mounted jetson nano module. We have tried flashing both Xavier NX and Nano production SOM. Xavier NX SOM is flashing without any issue. We are still facing issue in flashing Nano SOM.

We tried flashing from SDK manager and via flashing script to Nano SOM. Both are hanged in between flashing. We are using 180 13448 DAAA B01 version of Nano SOM. We noticed a strange behavior while flashing.

Can you please help us resolving the issue with flashing?

hello venkatraman.bhat,

are you tried to sharing the same carrier board for Nano and Xavier NX?
you cannot use both modules (Nano, Xavier NX) with the same carrier board, please also refer to Topic 144055 as see-also.

yes we have used same carrier board for both the models, we have tried this with other carrier board and working fine, I am attaching the screen shot where it hangs.

you cannot use the same carrier board since Nano module and Xavier NX module are not compatible.

We are trying on this carrier board : it is customized carrier board based on nvidia design

hello venkatraman.bhat,

this is not a reference DevKit. you must need a specific flash configuration files for image flashing.
please contact with your vendor for correct flash configuration files,
you may check Jetson Nano Product Design Guide and also Platform Adaptation and Bring-Up for reference,