Jetson Nano first time boot issue

I am having issues with the first boot of the Jetson Nano I recently bought. I am using Mac and Windows 10 VM on parallels. I have tried both conecting using Mac and using Parallels Windows 10 VM. On the windows machine in Device Manager, I see the following error:

Currently, this hardware device is not connected to the computer. (Code 45)

The hardware Ids for this (COM3) are:

I have restarted the Mac and windows 10 VM, but still the same issue. I checked the driver and it says windows has the latest driver. I am using the power from J25 (with Jumper correctly set) and using Micro USB to connect to the Windows 10 VM.

What can I do to overcome this issue?


Please have a host PC with native Ubuntu OS 18.04 to install SDK manager to flash your device.
The VM is not supported.

Can I get the first boot to work from my Mac? I see “Linux for Tegra” under System Settings > Network, but it says “not connected”. I was just following the instructions for Getting Started.

For host machince, that needs to be Ubuntu OS, but some people did get VM/Mac work, you may refer to Flashing Jetson Nano 2GB with VM

Thanks for helping me. It is nice to be able to get some help! I still have not tried Ubuntu VM, but before that I am trying to follow the instructions at: Get Started With Jetson Nano Developer Kit | NVIDIA Developer
I am using MacOS (not VM) and the instructions are not working. I looked at both headless mode and with display attached. In the headless mode, I am not able to see the USB device whenI issue the command ls /dev/cu.usbmodem*.

Does this mean that the Jetson Nano I just purchased is defective?

No, it is most likely a software issue. Not hardware.

You need to get a native ubuntu 18.04, install sdkmanager and let sdkmanager flash jetson from your ubuntu host.

So do I understand it right that I need to purchase a new computer that has Ubuntu 18.04 on it to make Jetson Nano work? I cannot even use Ubuntu on Parallels?

The VM is not officially supported, thus to use a true Ubuntu PC…this would be the easiest way…Otherwise, you would search this forum, but be aware that tricks would depend on your VM and L4T release…You may put your Jetson into recovery mode before launching your VM, and may try to adjust your USB settings

Below thread is a successful case without native Ubuntu PC, you can check if can help: Docker on Mac OS is unable to flash Jetson - Jetson & Embedded Systems / Jetson Nano - NVIDIA Developer Forums

Interesting. I hope someone from NVIDIA sees this and updates the Getting Started page to indicate that only Ubuntu PC will work. I will try to get an Ubuntu PC and give it a shot - hopefully that I will have better luck and the Jetson Nano purchase is not a complete waste (and possibly the Ubuntu PC purchase as well!).

Thanks for your support. I will update on what I find.

Do you know where I can find a laptop that has ubuntu 18.04? (I know it is kind of silly to ask this here, but I am finding it hard to locate it.) Thanks!


Before having a laptop with Ubuntu OS to install the SDK manager, Here are some tips to help on debuging issue.

Have you tried to write the SD card image to a microSD card by running Etcher on Mac? See
Get Started With Jetson Nano Developer Kit | NVIDIA Developer

If that’s not working, you may do the troubleshooting in the following manner.

  • Check if you see the green LED lights up when power is applied to the board.
  • Make sure the SD card is inserted in the correct way and all the way.
  • Try different display/TV, try different HDMI cable.
  • Make sure they downloaded and flashed the correct SD card image (for Jetson Nano 4GB or 2GB)
  • Format the SD card again, and re-write the image to SD card.
  • Try a different SD card

Yes. I just watched a youtube video that showed connecting to a TV worked. So I tried that and that seems to be working. I just need to get wireless keyboard and mouse to be able to interact with it. I should be able to do that soon. I will write down the steps here if I can get it to fully work.


Thanks for the help. Following are the steps I used to get it working.

1. Devices used:
Jetson Nano 4G development kit
5V-3A DC adapter
WiFi dongle (tp link)
Wireless keyboard and mouse with USB dongle (Logitech advanced MK540)
HDMI cable to connect to display
HDTV used as display
64GB MicroSD
2. Use a Mac or PC to download the Jetson Nano SDK
3. Use Etcher to flash the MicroSD with the SDK
4. Place the MicroSD in its socket
5. Plug in the WiFI dongle in any of the USB sockets
6. Plug in the USB dongle for the keyboard and mouse in another
7. Connect the TV to Jetson Nano with the HDMI cable
8. Make sure the jumper is used to connect the two pins (at J48)
9. Connect the power to the Jetson Nano board at J25
10. The processor will boot up and will show some screens:
I chose all defaults
11. Created a login:
Initially I had a password with a special character. This did not work at a later stage when I wanted to connect with Remote Desktop. It looks like the keys from the Remote Desktop do not get translated correctly when communicated to Jstson Nano. So had to change it to something very simple
12. Remote desktop connection:
Install xrdp: sudo apt-get install xrdp
In the file /etc/xrdp/sesman.ini add the following line:
The above line should be added under [Security]
Restart xrdp using: sudo service xrdp restart
Get the IP address of Jetson Nano by using one of the commands: ifconfig or “ip addr show”
From the PC start Remote Desktop and connect with the above IP Address
Enter the username/password
If everything works, you should be able to see a connection to Jetson Nano and interact with it
It did not work for me and the window was closing immediately after connecting
You can look at the file /var/log/syslog using sudo tail /var/log/syslog on Jetson Nano to see what the possible error could be
Since xrdp was not working, I installed xfce4 using the following commands:
sudo apt-get update
sudo apt-get install xfce4
echo xfce4-session > ~/.xsession
sudo service xrdp restart
Now start the Remote Desktop on the PC and connect with Jetson Nano. You should be Abel to see the connection and be able to interact with Jetson nano using a terminal in the Remote Desktop window.
At this point you should not need the TV display or the keyboard and mouse any more and be able to do all the work directly from the Remote Desktop.
13. Note that any time Jetson Nano is rebooted, its IP address may change and so you may have to get it by using the TV as the display for Jetson Nano.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.