Jetson Nano freezes after boot, says tegradc.1 error

Hello. Long time passed ))
Got returned to Jetson Nano by new year, done some work about upgrading my programms. But at January my main Jetson were “broken”. I were writing new code and suddenly it switched off. No info why. Just black screen.
Right now, i am trying for about a two weeks to start it again. Every time, LCD monitor is flashes with NVIDIA logo and then console says: tegradc.1: dpd enable lookup fail:-19 and then black screen.
Yes, i have read forums, i did flashed old image, yesterday i got downloaded (hurray! about four days of bad downloads which stopped at 1,9Gb…4Gb of archive. Seriously, do with that old problem something.) new image. Same story.
I did already used my secondary test Jetson Nano and got same problem.
I did borrowed working headless (no monitor yeah) Jetson, used my SD cards - same problem. Startup info, LOGO and freeze. LED at micro-USB connector stops also.

So, how i can get more info to you, so you can help me. Please. Very very please.

Got startup log.
Jetson Nano.log (19.9 KB)

  1. By default, there is a “quiet” keyword in /boot/extlinux/extlinux.conf and it will make the kernel log in silent. Thus, I only see few lines from your log in kernel aspect. It looks like system get into kernel but somehow gets stuck.

  2. If this module hasn’t been updated for long time, I would suggest you can use sdkmanager instead of sdcard image.

Get new SDK Manager and trying to make new SD card image.
Got this:

What to do?
Also, how can i make SD card image and download it into Jetson Nano SD card? Do i need to use Balena Etcher or somehow from SDKManager? Because SDKManager does not found any Jetson Nano.

I would suggest to file a new topic for your sdkmanager issue first.

Sdcard image is just for beginners to have a easy entry to jetson nano. Sdkmanager is still the better options when installing and debug.

The reason is written in this post.

Ok. Understand. But how i can download new image to Jetson Nano from SDKManager, when Jetson Nano is powered on, but cannot been found by SDKManager?
At first i used etcher to get image on SD (entry level), then used SDKManager to upload image created by SDKManager and then programing on working system.
But right now how can i do that, when Jetson Nano freezes? Do i need to use recovery jumper on dev-board? USB connection from Ubuntu+SDKManager to Jetson Nano? Any manual?

I think you need to know what is sdkmanager doing and what is sdcard image doing.

  1. Sdcard is just a all-in-one binary that has OS and SDK.

  2. Sdkmanager will download the full driver package (Linux_for_Tegra) on your x64 host machine first and then use tools to “flash” the driver package to your host as OS. After the OS is installed, it will then use IP to locate your jetson nano and send the SDK binaries to it and install.

Thus, when you use sdkmaanger, there is no need to worry about whether you need to prepare sdcard image or not. The answer is no, you don’t need to prepare the sdcard image for sdkmanager case at all. Just give an empty card and sdkmanager will handle the rest.

Currently, your problem is not “sdkmanager cannot find jetson nano”. Your problem is sdkmanager cannot download the driver package to your host machine.

But right now how can i do that, when Jetson Nano freezes? Do i need to use recovery jumper on dev-board? USB connection from Ubuntu+SDKManager to Jetson Nano?

You can refer to the Quick start guide, after you fix your sdkmanager problem.

I got apt update and apt upgrade, SDKManager now can continue to make SD Image. All good.

So, i got Jetson Nano with clean SD card into Flashing in Recovery Mode, by switching to Manual from SDKManager’s screen.
Waiting for flashing, may all gods give me their luck, haha.

Jetson Nano new.log (20.3 KB)
Here is log file.
No, not any good news. Again NVIDIA logo on all screen and then tegradc.1 error and Jetson frozen.
What to do?

I just want to confirm, your so-called “tegradc.1 error” is just some lines printed on the monitor, is that right?

And did you have any experience on jetson devices before? Because I am not sure if I need to say those first setup things again as I have told to many other users.

You need to finish the first boot up configuration through either monitor or headless method. Since your desktop cannot show up now, I guess you can only use the headless method.

Also, what is the size of your sdcard?

No, it is printed into terminal, i use putty to see logs from Jetson Nano.

I do have experience with Jetson Nano, got two of them, got myself car numberplate detection programm, which i wrote directly on Jetson.

I cannot finish first boot up configuration, simply cannot because all my Nano’s are freezes at boot up, power LED switches off, fan blades spinning (+5V is present, yeah), no access from terminal, no access through Ethernet connection (there is no ethernet connection with not empty SD card, without SD card i can see Jetson from ehternet router console).

I do understand that you are told newbies this simple truth, that they must finish first bootup, BUT I NOT GOT ANY first bootup from about new year’s eve.

SD card is 32Gb, both, and both of them already worked on those cards.
How can i switch to headless mode, edit some file? Which?
Please help, i really understand dumbness of situation, but it is not “again newbie” problem.


  1. So the monitor side is blanked?

  2. Please connect the micro usb cable to the port you are using to flash the board, boot up the jetson nano and check if there is a /dev/ttyACM0 on your host side. If there is, use minicom or putty to open it and see if it gives some interface like below.


power LED switches off,

This is a serious one that I am not sure if this is true on your side. You are saying there is log printed from the uart but there is no power LED?

Yes, before “the freeze” LED is powered on, all good, bootloader cheking SD image, it is trying to load OS. Got NVIDIA logo, “the freeze”, tegradc.1 - last message in console and LED switches off.

Will try to connect with ACM0, but before i already tried to connect Jetson to USB, there was no ttyACM0. Well, i do uploaded new image, maybe it will work.

What is “new image” here? You want to reflash the sdkmanager again?

Will try to connect with ACM0, but before i already tried to connect Jetson to USB

You can firstly check if lsusb gives you “nvidia corp” and then we check the ttyACM0. If lsusb on host has the nvidia corp but the device node ttyACM0 is not there, then you could also dump the dmesg on host side. Probably missing drivers.

Another trick is remove the “quiet” in Linux_for_Tegra/rootfs/boot/extlinux/extlinux.conf and then flash the board again.
With this setting, more kernel log will be dumped from UART, you shall see more log other than the tegradc.1 log.

BTW, I don’t really treate tegradc.1 log as a problem because it can be seen even in normal boot up process.

No, i do name flashed image as “new” :-)

Ok, will do.

Yes, i understand, i do remember now, half-a-year ago i do saw this “tegradc.1” error in terminal, when testing custom board. Also, i do know, that i can remove “quiet” from extlinux.conf by mounting SD card with Linux and sudo nano …/extlinux.conf. Is it right, or i need to reflash SD card image?

Both methods are fine.