Jetson Nano GPIO example problem

How you resolved your issue ??

I am getting the same high-frequency ‘noise’ as referenced above with the voltage ranging from 1V to 2V on the oscilloscope running the sample code. The ringing is about 50MHZ in my case using standard scope probes. I can’t believe I am unable to drive an oscilloscope!!! What is going on here???

I am trying to configure DPDT toogle switch to jetson nano to toggle between two directions of switch and readign the input of GPIO pins in both the directions. Unable to read the correct input value from the GPIO pins. Tried with wait_for_edge, event_detected functions of jetson nano. Please suggest us I am doing in correct way or not. some times event is detected and GPIO value is set to that only and not getting it to 0.

When using Multimeter, the GPIO will measure ~1.6 (high) or ~1.58V (low). However when use with logic IC, it is ok. Can trigger high or low without Multimeter. Looks like Jetson Nano GPIO has very low tolerance on capacitive loading…I see spec is around 70pF.


This Paul McWhorter tutorial will walk you though using a transistor to control an LED with the Nano GPIO pins: AI on the Jetson Nano LESSON 56: Using the GPIO Pins on the Jetson Nano - YouTube

1 Like


I’ve got a device that takes in a 3.3V signal; however I am experience the same issues as described here. Based on what you have describe, I’m thinking that this device has a high internal capacitance. Is there anyway to add some circuitry between the GPIO and the signal line to avoid this issue?


1 Like

Please help to open a new topic for your issue. Thanks

I have read every comments but I could not find any real solution about gpio problem. I see approximately 1.5 V from oscilloscope even when I made them high from terminal with “echo”. So I need help why do I see absurd signal from output ?

1 Like

Hi berk.yildiz,

Please help to open a new topic for your issue. Thanks

berk.yildiz, We had success after switching our oscilloscope probe to 10x. This will help reduce capacitive loading.

For AGX Xavier only - and assuming you have jumper 514 set to pins 1 and 2:

The docs and io tools ‘imply’ that any unused pins on the 40 pin header can be used interchangeably for GPIO. A little exploration and examination of Developer Kit Carrier Board docs show that this is not true.

I found that only pins sourcing 1 ma or more reliably provide 3.3v as outputs. These are pins 11, 16, 29, 31, 32, 33, and 37. All the rest of potential GPIO pins (7,12,13,15,18,19,21,22,23,24,26,35,28, and 40] source 20 micro amps - just not enough to drive a realistic load. For example, my multi meter never shows the voltage on these pins above ~3.0.

Finally, pin 36 does not seem to source any useful current. I have not tried it on the scope but multimeter shows it as ~0 v regardless of output state. Docs list ‘-’ as potential drive current.