Jetson NANO - GPIO output setting by default

Hello,
I’m trying to test gpio output setting by default.
I applied pinmux output setting as follows :

Generated file as follows:

  • tegra210-porg-pinmux-p3448-0002-b00.dtsi
    image

  • tegra210-porg-gpio-p3448-0002-b00.dtsi
    image

And I build and flash DTB.

I checked output setting on Jetson NANO :

GPIO3_PB.06 => GPIO-14 => 0xe
GPIO3_PB.07 => GPIO-15 => 0xf

So, It looks my setting was applied.

But, there is no output signal by default.
I checked the extension header pin with a multimeter, there is no output voltage.
GPIO-14 => extension pin 13
GPIO-15 => extension pin 18

And kernel-gpio isn’t sat, also.
image

I wonder what i missed?
And how can i read current gpio status?

hello sumin.lee,

you may check via sysnode, /sys/class/gpio/.
for example,
SPI1_CS0 / GPIO3_PB.07, it’s gpio15,
you may export the pin manually, # echo 15 > export, then you’ll have gpio15 available.
thanks

Dear. Jerry Chang,

Actually, I already know the method what you answered.
https://elinux.org/Jetson/Tutorials/GPIO

I expected It is sat to high without any manual control, if I use pinmux to set as follow.
image

Could I set the gpio to high if I use pinmux?

hello sumin.lee,

it looks those configurations were correct, may I know how you probe the pin,
you may also check applications note of 40-Pin Expansion Header GPIO Usage Considerations about the level shifter.
thanks

I couldn’t find the way to use level shifter by user.
So, I created shell script and I registered it on /etc/init.d/ for setting automatically.