Jetson Nano - Keeping time updated after reboot

I always hate booting my Nano as the time and date is so fare off. It will not let me do a lot of things like well get on the internet.

I been trying to setup a working ntp updater but it keeps failing and not working at boot up.

Is there some other solution here or something the Jetpack should have to the date and time is kept more up to date?

Andy

Have you try set the Time & Date

I was doing this each time i booted up and half the time it would not update.

I ended up setting up NTP and adding it to boot up but the time slip take 2-3 minutes to sync back up.

NTP did not come installed so I am wondering if that needs to be added to JetPack.

Also is there a RTS module that can be added to the Nano?

I was curious about what appears to be coin cell battery holder pads on the bottom of the nano dev kit. Does that mean there is (or will be) a Real-time Clock chip somewhere on the board?

Yah I saw that too.

Andy

I managed an alternative solution, hope it helps.
https://github.com/justsoft/jetson-nano-date-sync

Great! Thanks for sharing!

1 Like

Another option is to use a better ntp mirror.

us.pool.ntp.org is a pretty good pooled mirror for people in the US.
pool.ntp.org is a mirror that’s good worldwide.
Or you can pick on someone who can afford it and go to time.windows.com :-)

First, make sure you have ntpdate installed:

sudo apt install ntpdate

Then, put this in your startup scripts or login script or whatever:

sudo ntpdate us.pool.ntp.org

However, note that systemd will run its own NTP client/daemon, that’s not the default ntpd. (Just like systemd replaces DNS, and most other services you’d expect from a classic UNIX system …)

jwatte@jetson-nano:~$ systemctl status systemd-timesyncd.service
● systemd-timesyncd.service - Network Time Synchronization
   Loaded: loaded (/lib/systemd/system/systemd-timesyncd.service; enabled; vendor preset: enabled)
   Active: active (running) since Wed 2019-06-26 17:39:08 PDT; 16h ago
...

The server used is configured in /etc/systemd/timesyncd.conf

Add a setting for

NTP=pool.ntp.org

and reload the service and it’ll sync from a service that exists and works.

thanks it worked

Hello,

It does not apply even if the timezone is changed,
When I reboot, it changes to a different time zone.
Could this solution you introduced help?

Thank you.