Jetson Nano libhdf5 installation problem

I am attempting to install tensorflow-gpu onto the Jetson Nano. One of the dependencies for this is the hdf5 library which is required for the h5py dependency for tensorflow.

When I attempt to install libhdf5-dev onto the Nano, the library cannot be found:

Building dependency tree       
Reading state information... Done
E: Unable to locate package libhdf5-dev

I have tried ‘sudo apt-get install libhdf5-dev’ with just ‘apt install’ and have tried ‘libhdf5-serial-dev’ in the installation command as well. The result is always the above. There is nothing wrong with the ‘apt’ command, other libraries have no problem downloading. I have already run ‘apt update/upgrade’ multiple times.

‘universe, multiverse, main, restricted’ repositories for Ubuntu software are all active.

From looking at the website for hdf5 releases: https://packages.ubuntu.com/bionic/libhdf5-dev it seems there are no active links to download the library from source for arm-64, while there are many links for other structures e.g. for amd64.

Without this dependency the pip installation of tensorflow-gpu fails. I would like to know how to solve this, or whether there is a separate, documented route for installing tensorflow with gpu support for the Jetson Nano

Hi,

You can get hdf5 with this command:

$ sudo apt-get install libhdf5-serial-dev hdf5-tools libhdf5-dev

We can execute the command without issue, would you like to try it again?

Thanks.

I have tried that many times, it results in the same:

$ sudo apt-get install libhdf5-serial-dev hdf5-tools libhdf5-dev
$ Reading package lists... Done
$ Building dependency tree       
$ Reading state information... Done
$ E: Unable to locate package libhdf5-serial-dev
$ E: Unable to locate package hdf5-tools
$ E: Unable to locate package libhdf5-dev

Also, I went onto Ubuntu Software in Settings, changed the ‘main server’ to ‘server from [my country]’ and changed it back to ‘main server’, when I click on ‘Close’, I receive a pop-up saying:

‘The information about available software is out-of-date’

with an option to ‘reload’, when I click that it opens a pop-up saying ‘Updating cache’ but then says ‘Failed to download repository information, check internet connection’. But I have an active internet connection so why would the Nano fail to download the repository information?

Thanks for any help.

Hi,

Which OS version do you use?
If the error keeps occurring, would you mind to reflash it with the latest JetPack4.3 installer?

It looks like there are some issue in your apt-repository.
Could you share the log from this command with us?

apt-cache policy

By the way, have you tried these setting?

sudo apt-get install software-properties-common
sudo add-apt-repository universe 
sudo add-apt-repository multiverse

Thanks.

Hi,

I attempted settings 2 and 3, but not 1 (“software-properties-common”), they didn’t do anything as it still could not install.

I have fixed the issue by reflashing it with the JetPack installer and the repositories are functioning normally now, the library has successfully downloaded. It seemed as if there was something wrong with the ‘sources.list’ document in my previous install after adding certain NVidia-docker repositories with ‘add-apt-repository’, as this is where the 404 error came from when I tried to use

sudo apt-get update

. This time I have not attempted to download docker containers and the ‘apt update’ functions perfectly.

Could I somehow access some documentation on how to run specifically DeepStream, Tensorflow and TensorRT docker containers on the Jetson Nano, it seems the Nvidia GPU Cloud instructions for these containers are for the x64 architecture while the Jetson is arm64, which may be what is creating the errors when trying to access the apt repositories?

Hi,

These are user level libraries.
It’s expected that the usage of user-level library between x86 and Jetson should be similar except from the installation.

All the Jetson-based libraries should be installed via JetPack directly.
https://developer.nvidia.com/embedded/jetpack

After that, here are some related document for you reference:
Deepstream: https://docs.nvidia.com/metropolis/index.html
TesnorRT: https://docs.nvidia.com/deeplearning/sdk/tensorrt-developer-guide/index.html
TensorFlow: https://github.com/NVIDIA-AI-IOT/tf_trt_models

Thanks.

Thanks, was stuck hdf5 and h5py ( :