Jetson nano libhdf5-serial-dev install issue

When I install python3-pip,libhdf5-serial-dev and hdf5-tools on my Jetson Nano board.
python3-pip and hdf5-tools is fine, but installation of hdf5-tools has some error as follow.

yaobmc@R2D2:~$ sudo apt-get install libhdf5-serial-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libhdf5-serial-dev : Depends: libhdf5-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
yaobmc@R2D2:~$ sudo apt-get install libhdf5-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libhdf5-dev : Depends: libjpeg-dev
E: Unable to correct problems, you have held broken packages.
yaobmc@R2D2:~$ sudo apt-get install libjpeg-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libjpeg-dev : Depends: libjpeg8-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
yaobmc@R2D2:~$ sudo apt-get install libjpeg8-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libjpeg8-dev : Depends: libjpeg-turbo8-dev (>= 1.1.90+svn722-1ubuntu6) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
yaobmc@R2D2:~$ sudo apt-get install libjpeg-turbo8-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libjpeg-turbo8-dev : Depends: libjpeg-turbo8 (= 1.4.2-0ubuntu3.1) but 1.5.2-0ubuntu5.18.04.1 is to be installed
E: Unable to correct problems, you have held broken packages.

Is ‘sudo apt-get install libjpeg-turbo8=1.4.2-0ubuntu3.1’ right?
Is there any other way to solve the issue?

Hi 544644395,

Please try below command and install again:

sudo add-apt-repository universe
sudo apt-get update
sudo apt-get install libhdf5-serial-dev
1 Like

The issue is solved. Thanks.

I have the same issue:

ybli@ybli-seecar:~$ sudo apt-get install libjpeg-turbo8-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libjpeg-turbo8-dev : Depends: libjpeg-turbo8 (= 1.5.2-0ubuntu5) but 1.5.2-0ubuntu5.18.04.1 is to be installed
E: Unable to correct problems, you have held broken packages.

I have tried your commond, but I can’t solve this issue.

ybli@ybli-seecar:~$ sudo add-apt-repository universe
'universe' distribution component is already enabled for all sources.
ybli@ybli-seecar:~$ sudo apt-get update
Get:1 file:/var/cuda-repo-10-0-local-10.0.166  InRelease
Ign:1 file:/var/cuda-repo-10-0-local-10.0.166  InRelease
Get:2 file:/var/visionworks-repo  InRelease
Ign:2 file:/var/visionworks-repo  InRelease
Get:3 file:/var/visionworks-sfm-repo  InRelease
Ign:3 file:/var/visionworks-sfm-repo  InRelease
Get:4 file:/var/visionworks-tracking-repo  InRelease
Ign:4 file:/var/visionworks-tracking-repo  InRelease
Get:5 file:/var/cuda-repo-10-0-local-10.0.166  Release [574 B]
Get:5 file:/var/cuda-repo-10-0-local-10.0.166  Release [574 B]
Get:6 file:/var/visionworks-repo  Release [1,999 B]         
Get:6 file:/var/visionworks-repo  Release [1,999 B]
Get:7 file:/var/visionworks-sfm-repo  Release [2,003 B]                       
Get:7 file:/var/visionworks-sfm-repo  Release [2,003 B]                                                
Get:8 file:/var/visionworks-tracking-repo  Release [2,008 B]                                           
Get:8 file:/var/visionworks-tracking-repo  Release [2,008 B]                
Hit:10 http://ports.ubuntu.com/ubuntu-ports bionic InRelease                
Reading package lists... Done                      
ybli@ybli-seecar:~$ sudo apt-get install libhdf5-serial-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libhdf5-serial-dev : Depends: libhdf5-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
ybli@ybli-seecar:~$ sudo apt-get install libjpeg-turbo8-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libjpeg-turbo8-dev : Depends: libjpeg-turbo8 (= 1.5.2-0ubuntu5) but 1.5.2-0ubuntu5.18.04.1 is to be installed
E: Unable to correct problems, you have held broken packages.

Hope your answer, thanks.