Jetson Nano Low Voltage Warning


I’m facing an issue with power module(5V, VDD_IN): Tried to connect one camera, one wireless dongle(mouse) and one USB memory stick to the USB ports, system was warning with: System is now being throttled, system was throttled due to low input voltage.

As I tried to check the VDD from /sys/bus/i2c/drivers/ina3221x/6-0040/iio_device, I found that if no USB device was plugged in, the value for “in_voltage0_input” is around 4960, which is 4.96 V, once I connect the camera, dongle and USB memory stick, it drops to 4680 which is 4.68 V, thus causing the warning and sometimes makes the camera not working.

Also I tried to replace the DC power supply with a controllable source, I found that from the DC power supply, the output voltage is correctly at 5V, which is strange that the INA3221 measured VDD_IN is dropping to 4.68V. Additional external USB device should not cause the voltage drop. Could you kindly help to check the root causes and possible solution.

hello yawei.yang,

could you please share the kernel messages when USB devices connected, please check if there’s suspicious errors.
you may also refer to Topic 71637 for power supply considerations. thanks

Hello Jerry,

Thanks for your suggestion, I checked kernel messages, there is no special suspicious errors related with USB device.

We are using the DC jack(5V 4A) for the power supply, I found that at the reference schematic design, TPS25944 is used for the power MUX and protection, and TPS25944 has a typical resistance of 42 mΩ, so when the current came to 1.5A, this chip will take a voltage drop around 70mv, and if the current came to 2A, it would take voltage drop around 100mV, which makes the 5V VDD_IN at 4.85V, and this will be around the boundary for USB devices power supply.

Do you have any suggestions that we can do to compensate the voltage drop of TPS25944 and the circle resistance of board itself?


The rated VDD_IN is 4.75 ~ 5.25V, it looks like you have attached too many devices that draw too much current and cause the voltage drop. The only way is to use a power supply with higher voltage such as 5.25V.

Thanks Trumany,

Agree, that could be the currently solution for us, just one question: If we apply a higher voltage power supply, will that impact the reliability and lifetime of the Jetson/USB device?


No if voltage is in the range.

I encounting the same issue with different batteries and voltage inverter. Typically, battery output are 5v. It’s difficult to get 5.25.
Is there proper way to connect batteries to Jetson Nano ? What is the upper range voltage (5.5v)?
Thanks in advance

The absolute maximum rate of it is 5.5v. Did you try two 5v batteries in parallel?

Thanks for the upper limit.
I tried an 30AH 5v with 3A output battery and
40AH 12V with 12vto5v inverter at 3A.
Both experiencing showing the “The system is now at throttle mode” message.
I tried it with both connections(micro & jack ). The voltage with jetson nano on is at 4.98v. So, there is not much voltage drop.

The message does not shows up when 2A DC plus is used.

Any suggestions on finding a battery power solution ?

That looks like the battery capability issue. You should use a oscilloscope with enough bandwidth to capture if any voltage drop during heavy workload. In theory, if DC power can work normally, then it should be the battery problem.

Hi Terry,

You can also try check input voltage for the CPU/GPU by checking information under: /sys/bus/i2c/drivers/ina3221x/6-0040/iio_device, in our case, when connected devices which consume relativly large power, system would take a current around 1.5A, considering the efuse and load switch has typical resistance around 150mΩ, even the DC_IN voltage is within 4.75~5.25V, the voltage input to CPU/GPU could be lower than 4.75V.

We are also bothered by this issue, the better solution would be add the DC/DC in your carrier board and use higher voltage input like 12/19V and convert to 5V then.

Hi Trmany & Yawei,
Thanks for the suggestions.
I order an 5A intervor. It still shows the warming message.
I endup removing the USB memory stick and USB monitor. The message went away.
It looks like the warning message is due to the USB current draw.