Jetson Nano M2 <> SSD adapter (Key M to Key A+E) Kernel Error

Hey,

Following the post here - can this board use m.2 ssd nvme

I have read almost all the posts here, still without a practical solution.
Jetson Nano setup with M.2 Key-E to Key A+E, upon boot, I get the following kernel errors:

kernel: pcieport 0000:00:01.0: broadcast error_detected message
kernel: pcieport 0000:00:01.0: broadcast mmio_enabled message
kernel: pcieport 0000:00:01.0: broadcast resume message
kernel: pcieport 0000:00:01.0: AER: Device recovery successful
kernel: pcieport 0000:00:01.0: AER: Multiple Uncorrected (Non-Fatal) error received: id=0010
kernel: pcieport 0000:00:01.0: can't find device of ID0010
kernel: pcieport 0000:00:01.0: AER: Multiple Uncorrected (Non-Fatal) error received: id=0010
kernel: pcieport 0000:00:01.0: PCIe Bus Error: severity=Uncorrected (Non-Fatal), type=Transaction Layer, id=0008(Requester ID)
kernel: pcieport 0000:00:01.0:   device [10de:0fae] error status/mask=00004000/00000000
kernel: pcieport 0000:00:01.0:    [14] Completion Timeout     (First)

Any ideas?

Thanks.

Sorry for the late response, is this still an issue to support? Thanks

Yes. Still no luck running through M2 nvme.

Thanks

Could you please check if your system has ASPM states enabled? If yes, please disable them and try.
Here are the ways to disable ASPM states in the system.

  • Disabling from the beginning
    • Appending ‘pcie_aspm=off’ to the kernel command line
    • Removing “CONFIG_PCIEASPM_POWERSAVE=y” and setting “CONFIG_PCIEASPM_PERFORMANCE=y” in the kernel configuration
  • Disabling after system boots to console
    • Executing the below command once the system boots to console
      • echo “performance” > /sys/module/pcie_aspm/parameters/policy

Also, please add “nvidia,disable-clock-request” to the PCIe device-tree node to avoid any dependency on the CLKREQ (clock request signal) of the endpoint.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.