Jetson Nano module doesn't start (not a booting issue)

Hello!

I have been running a B01 emmc module in our carrier board for some time now and it worked good.
Last time I powered it down with “sudo poweroff” and unplugged the power. 5 minutes later upon re-plugging the power back Jetson nano refuses to start - the SYS_RESET is not raised by the module.
Nothing was connected to the board during those 5 minutes, nothing touched it physically.
The 5V rail on the carrier is OK, so the module is powered.
I tested other modules with this carrier, they all boot normally.
I tried the faulty module in other boards - it doesn’t work.
So it’s really the module that is faulty.

Could you suggest any possible reason? I really hope that it did not get damaged by the carrier board since that would question the whole custom board design, which has been working flawlessly for several months now…

I would be grateful for any hints!

Best regards,
Olex

For a normal module, if reset is not released to high, the power rails on carrier board will no be ON. So it looks like this module is damaged, you can run RMA for it.

Did anyone experience something similar?