Jetson Nano Network not starting until after login

So I have tried a variety of things, but my Nano’s network doesn’t appear to come online until after the first login with a user name and password. I had auto login with gnome and everything worked as I expected, plugging in the nano made it available on the network. I wanted to save on RAM however since I only need to access the board through SSH, and it is on a robot so it is powered off frequently. I tried switching to LXDE to save memory, and started to see this behaviour. Power save for the wireless was set to power_save off. I also then used sudo systemctl set-default multi-user.target to just avoid the GUI altogether, but the issue persists. I am using the Intel Dual Band Wireless-Ac 8265 w/Bluetooth 8265 module.

How can I get the network setup to start on boot without have having to log in first?

This is the default behavior for WiFi. Any documents on the web for Ubuntu WiFi will likely apply. Without customization it is intended to make WiFi something like a “personal” thing with individuals having their own password. This is what you would call a “managed” connection via NetworkManager. There could be more than one way to solve this, but I found this URL which seems to have ways that would work over a range of Ubuntu releases:
https://askubuntu.com/questions/16376/connect-to-network-before-user-login

I am guessing the one (of the different setup methods mentions) to start with is the one which mentions “/etc/NetworkManager/system-connections/”. Does anything there help?

Thank you @linuxdev that helped a lot. I couldn’t get the /etc/NetworkManager/system-connections/ to work, but in the GUI Desktop selecting Network Connections -> My SSID -> and checking the box to allow for this network for all users worked. I could then set systemctl to multi-user.target and I am saving 500MB+ memory now!