Jetson nano no display and power led is on

I’m running into a problem with my Jetson Nano. it’s not showing any display. Even though the power light is on. I’ve tried everything. Swapped out power supplies and screens, tested both HDMI and DisplayPort connections, and even re-downloaded the .img file to redo my SD card setup on a different computer, just to be safe.

  1. If you want us to help analyze this issue, you need to dump serial console log from device.
    https://www.jetsonhacks.com/2019/04/19/jetson-nano-serial-console/

  2. If you don’t want to dump log, then you can flash the whole board with sdkmanager from another ubuntu18.04 x86 host. Please be aware that this method is totally different from sdcard image. What sdcard image cannot fix would be fixed by sdkmanager. BTW, this method will erase the content on sdcard too.

i tried to flash it from the sdk manager but this error showed

There is a EEPROM on the module and you corrupted that thing before. That was what happened.

Sorry its my first time using jetson nano and i dont understand what do you mean by corrupted eeprom and what is the reasons makes it corrupted also is there is a way fixing it

Use the serial console to see if it can access the board first…

There is a eeprom on the Jetson nano module which has the information of this module.

When sdkmanager tries to flash the board, it will read the module info from this, but the checksum info from your eeprom has wrong info so flash failed.

It is most likely you corrupted this accidentally and not aware of it …

i tried serial debug console but this error showed:

error.txt (29.5 KB)

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.