Jetson Nano not booting with a different OS

The image from Nvidia works fine for the Jetson Nano, no problems there. I then wanted to use a different OS, and burned that to the sd card but then the Jetson was stuck at the Nvidia logo. I then used the serial to view the output (attached). It looks like for some reason it can not read the boot file with this particular OS.

Someone else I know tried the same image, on their Jetson Nano and it worked fine.

Re-burning the Nvidia image back onto the sd card and again everything starts fine, so I don’t think it is the sd card failing? Also not an issue with the different OS I am trying to run as that works on someone else’s nano.

The different OS I am trying is the BalenaOS.

Thank you.

boot_serial (2).txt (21.3 KB)

Hi Scotty123,

We never tried with BalenaOS, so can’t answer your questions.
Please contact with the person who tried the same image successfully to see if can help you.

Thanks

They didn’t do anything special, just burned the image to the sd card and it worked first time. I do have their boot log though if that helps. They are not sure why it works in their case and not mine.
boot_serial.txt (77.2 KB)

@Scotty123 could you please share what balenaOS version are you trying to use? Where did you download it? Thanks!