Jetson Nano not working with TP-Link TL-WN823N (8192cu chipset)

We are trying to setup drivers for this USB modem but not working, Even after blacklisting default drivers, We couldn’t be able to make it work.

If we are using default driver it’s continuously disconnecting.

Could share more information about this issue?
When disconnected, do you see any hint from dmesg?

If the signal is too weak to keep the connection, it is easy to disconnect.

Signal strength is fine, It’s just not connecting with any network. Neither in GUI nor in terminal, It’s just showing disconnected message and disconnecting from network.

We have tried to connect open network too. It’s also not connecting. When we are using default driver it’s just connecting and disconnecting within few mins

@alanz
here’s the timeline of what happened.

problems faced:

  1. gets disconnected within few minutes of activity
  2. no automatic connection after log in.

timeline:

  1. TP-LInk TL-WN823N when connected works fine and gets disconnected within a few minutes of network activity(81xxxu driver was installed automatically).
  2. a quick fix on the internet forms showed 8192cu, an old driver could be a buggy, then I blacklisted it so that 81xxxu can work. didn’t work.
  3. https://github.com/pvaret/rtl8192cu-fixes, solutions were followed from this repo to install fixes for driver. after the installation, the device isn’t detected.
  4. rolled back everything to default driver

Hi,

Could you try the driver with option 1. which works in the first connection.

Then try with settings from https://github.com/pvaret/rtl8192cu-fixes/blob/master/8192cu-disable-power-management.conf .

For options 3, the driver is too old. I think we need to find the proper driver work for ubuntu 18.04.

Also from my side, I’ll try to research too.

Hello @alanz, If you not so, can you suggest me a proper usb modem which works fine with not much hassel in India as edimax is also not easily available here

You can try with rtl8822ce, intel 8265NGW, TL-WN722N, WUSB6300.
You also can try to disable the powersave mode: sudo iw dev wlan0 set power_save off to see if the disconnection is still there.