Jetson Nano - OpenCV installation NVCC does not support GPU architecture

Hello there,

I am new to NVIDIA SDK. I was trying yo install OpenCV on my brand new Jetson Nano and I got “nvcc fatal error: unsupported gpu architecture compute_87”. I read that this is a know problem but I cannot find anything specific for my Jetson. My CUDA version is 10.2, I tried to update to 12 but nvcc seems to not work on that version.
I am using the “install_opencv4.6.0_jetson.sh” script from NVIDIA to make it fast.
How can I fix this?

Thank you in advance

You would try https://github.com/AastaNV/JEP/blob/master/script/install_opencv4.5.0_Jetson.sh.

Not tested opencv-4.6 with Nano, but if you wanna try, you would adjust the configure command on line 62:

cmake ... -D CUDA_ARCH_BIN="5.3" ...

Hi,

As Honey_Patouceul mentioned, compute_87 is Orin GPU architecture.
For Nano, please change it to 53.

Thanks.

Thank you for your reply! It worked in the sense that it allowed me to overcome that problem, but at 100% I got warnings that some libs were missing/not working and the procedure froze my Jetson. Now it looks like OpenCV is not yet installed unfortunately

I see… Nano may not have enough memory for parallel build.

Be sure to have some extra swap, and build with -j1 so that only one job is executed.
It may be long, I’d suggest to build during the night…

Thank you for your help!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.