Jetson nano , pi camera, streaming in H265

This is my very first time here so hello to everyone :) .

I have a question related with video streaming over lte.
I have jetson nano 2GB connected with Raspberry Pi camera v2, and I’m struggling to stream video from pi camera using H.265 format.

I’m using following code

server :

gst-launch-1.0 -e nvarguscamerasrc ! ‘video/x-raw(memory:NVMM), width=1920, height=1080, format=NV12, framerate=30/1’ ! nvv4l2h265enc bitrate=8000000 ! rtph265pay mtu=1400 ! udpsink host= port=5000 sync=false async=false


gst-launch-1.0 udpsrc port=5000 ! application/x-rtp,encoding-name=H265,payload=96 ! rtph265depay ! h265parse ! queue ! avdec_h265 ! xvimagesink sync=false async=false -e

In general H.264 is working quite good. However I want to improve latency so I would like to use H.265.
I’ve read in pi camera spec that is supporting h.264 so this is a potential root cause ? Or I’m doing something wrong from different side ?

thanks for help

Please set the properties to nvv4l2h265enc and try again:

  maxperf-enable      : Enable or Disable Max Performance mode
                        flags: readable, writable, changeable only in NULL or RE
ADY state
                        Boolean. Default: false
  idrinterval         : Encoding IDR Frame occurance frequency
                        flags: readable, writable, changeable only in NULL or RE
ADY state
                        Unsigned Integer. Range: 0 - 4294967295 Default: 256

  insert-sps-pps      : Insert H.265 SPS, PPS at every IDR frame
                        flags: readable, writable
                        Boolean. Default: false

And please link with h265parse like

... ! nvv4l2h265enc ! h265parse ! rtph265pay ! ...

For profiling latency, you may refer to
Gstreamer TCPserversink 2-3 seconds latency - #5 by DaneLLL

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.