Jetson Nano pointing to Kernel old version after upgrade


I recently upgrade my Jetson Nano 4GB production module 16GB eMMC booting from a M.2 PCIe Gen 3 x4 128GB SSD NVMe running this command:

sudo apt-get update && sudo apt-get upgrade

After the upgrade some of my peripheral stop working. Mainly I have trying to make an Edimax N150 rtl8723bu work again. Previously I made the device work by following this steps ( Adding WiFi to the NVIDIA Jetson - SparkFun Learn). So I tried to repeat them again by removing the previous drivers using this command:

sudo dkms remove <device>/<version> --all

When I tried to install the driver again an error pop up on terminal saying: Unable to locate package linux-headers-4.9.253-tegra

The previous Kernel version on the jetson was 4.9.253-tegra but the current one is 4.9.299-tegra. Checking in C:, the 4.9.253 kernel version has been erased and replaced by 4.9.299.

Interestingly enough, when running:

uname -r

The output is: 4.9.253-tegra

So somehow, the jetson is still pointing to the previous Kernel version. So I can think of two options:

  • To make the jetson nano point to the updated Kernel version
  • To have installed the previous kernel version together with the new one or downgrade to the previous version.

I am more keen on the first one as probably the second one can lead to issues by having two different kernel versions at the same time. Either way not sure how to proceed. I have much work done on this jetson so flashing is not an option I could afford at this point.

I tried to replicate the same error using another NVIDIA Jetson Nano 4GB production module 16GB eMMC (this one booting from eMMC) with same previous version (4.9.253 -tegra). After the upgrade the unname -r command is pointing to the right Kernel version and the drivers are updated correctly and running well.

I have been following some replies from @linuxdev but nothing about a misleading kernel version. Hope you can help me out.

Thanks in advance.

Just a clarification of my own post: the jetson nano is still booting from the 16GB eMMC. However, the root file system is located on the M.2 PCIe Gen 3 x4 128GB SSD NVMe.

Sorry for the late response, is this still an issue to support? Thanks

Hi, kaycc. Yes, I sorted it out. I copied the 4.9.253-tegra folders from the eMMC to the SSD. That way the peripherals worked again. Probably not the most elegant solution but the most straightforward.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.