Jetson Nano - Problem to install nearly any software

Last intent: Timeshift (see log attached) Timeshift install 200426.log (6.6 KB)
Tried 12 different installing methods, including Ubuntu repository. There the most software is outdated.
Couldn`t install for example

  • Brave - may be for the ARM architecture
  • RawTherapee: outdated version 5.3 in the repository, doesen`t work, newer version impossible to install.
  • DarkTable: outdated version, newer version impossible to install.
  • Gimp: outdated version in repository, after 2 days of work I got the newest version working.
  • VLC: after a Day of work I got it running, but doesen`t support 4k, likeTotem, that comes with the JetsonPack
  • FireFox: intents without result so long
    and so on.
    Some one a hint?

Issue seems are related to the applications, not specific issues on Jetson Nano, may other developers share their experiences.

FYI, adding a PPA implies a web server repository to search “in general”. For your logs I see:
http://ppa.launchpad.net/teejee2008/ppa/ubuntu
…you can go there with a web browser and look around. Ubuntu 18.04 LTS is also known as “bionic”, and so “bionic” subdirectories apply. An example of the main packages repository is:
http://ppa.launchpad.net/teejee2008/ppa/ubuntu/dists/bionic/main/

Within this there are subdirectories for various architectures. Shell scripts don’t have an architecture, but most files do. A binary file compiled for a Nano requires using the “binary-arm64” subdirectory:
http://ppa.launchpad.net/teejee2008/ppa/ubuntu/dists/bionic/main/binary-arm64/

The “Packages.gz” is a compressed list of available packages on that server under “main”. If you look at that file you will find it is empty. This server does not support any arm64 packages for Ubuntu 18.04 (bionic) main repo files. If you go to the installer directory, you will find the same result for arm64:
http://ppa.launchpad.net/teejee2008/ppa/ubuntu/dists/bionic/main/debian-installer/binary-arm64/

Basically, even if that package is available with that PPA, then there is nothing there for arm64 architecture.

You might still be in luck with source code. Go here, and examine the list of Sources:
http://ppa.launchpad.net/teejee2008/ppa/ubuntu/dists/bionic/main/source/

I see “timeshift” in that list. A relative directory location shows “pool/main/t/timeshift”. This is relative to the entire PPA server, so:
http://ppa.launchpad.net/teejee2008/ppa/ubuntu/pool/main/t/timeshift/

I do not know for this case which release is compatible with Ubuntu 18.04 LTS, perhaps the release versions are unrelated to this and you’d simply want the latest 19.x release, or perhaps only an older release works on this if 19.x is for one of the desktop releases on the bleeding edge. Regardless, I see many of these are “.deb” packages, and that none of them are for “arm64”. It may be that the “.tar.xz” version can be compiled natively on the Nano for source form…don’t know. An example you could experiment with:
http://ppa.launchpad.net/teejee2008/ppa/ubuntu/pool/main/t/timeshift/timeshift_19.08.1-0~201908111351~ubuntu19.10.1.tar.xz

Otherwise you would have to ask for the author or packager to support 64-bit arm64/aarch64/ARMv8-a. Since 32-bit armhf shows up, perhaps they would have that interest.

Thank you very much. Ill work through this. Its a long list!
I already suspected that it has to do with the arm-architecture.
But that was the reason to buy the Jetson nano, to experiment with this architecture.
First lesson learned: seems that there isn’t a lot of “normal” software for this architecture. Not jet.