Jetson Nano Production module

Hi all,

I’m using the LITA Carrier board with 4 cameras and SD CARD and Simcard. I’m trying to boot from the SD CARD when I’m using the Jetson Nano Production module, because trying to install the Jetson-inference I don’t have enough space.
When I use the Jetson Nano Developer SDK or Jetson Xavier NX all works fine, but not with the module with 16gb. For this reason I need it.

I tried to install the docker in a mounted folder, but always the space is running out.

Some suggestion about how to install the operating system in the SDCARD or to install the libraries in the SDCARD or other idea!

Thanks !!

Hi @BARO, I can’t speak to putting the OS on SD card (perhaps someone else from the community can help with that), however to move Docker to your SD card, did you set the data-root variable in your /etc/docker/daemon.json config?

This is what mine looks like:

{
    "runtimes": {
        "nvidia": {
            "path": "nvidia-container-runtime",
            "runtimeArgs": []
        }
    },

    "default-runtime": "nvidia",
    "data-root": "/media/nvidia/WD_NVME/docker"
}

(my user is ‘nvidia’ and my drive is mounted at ‘WD_NVME’)

For this to work, you will first want to make sure that your SD card is mounted at boot (i.e. it has an entry in /etc/fstab), because the Docker daemon starts-up at boot and needs that directory specified in data-root to be available. You can check it worked with sudo docker info

Also, you would probably want to clone jetson-inference repo to your SD card too, because the models get downloaded to your local repo and mounted into the container.

I tried to move the docker to the SD Card, but to install it I need the Nvidia-jetpack installed and this fill the Emmc at 98% then finally is not possible to install the docker image completely.

Then I believe that the key is to put the OS in the SDCARD to work correctly and discard the internal Emmc.

All the jetson platforms share below method to mount file system on external drive.

https://elinux.org/Jetson/L4T/Boot_From_External_Device

It is different from totally boot OS from external drive, but it will resolve the disk space issue.

thanks. It was very useful. now I have a normal problem with the sd configuration in my device tree. but looking the solution inside the forum.