Jetson Nano PWM Cooling Fan cannot change PWM RPM

Hi all,

I know this topic has been covered many times, but it seems my problem is a little different.
I originally purchased a Noctua FAN for the jetson nano, but only after delivery I figured it’s a 3 PIN one but I used it plug in without the tachometer PIN although it was on all the time at 100% too.

Recently I got tired of the noise and while purchasing some other stuff I also got a 4 PIN PWM fan here: Cooling Fan For Jetson Nano - DFRobot

Anyway, it seems the actual RPM of the fan won’t change with this fan either. From the moment I put the barrel power connector in, the fan starts 100% and remains that way no matter what I do.

  • I have the B01 version of nano, using the PWM fan 4 pin connector
  • I have jtop to see and modify the fan speed - no matter what I set it to, still at 100%
  • manual setting of ‘target_pwm’ does not change the fan speed either
  • I installed jetson-fan-ctl and I can clearly see the dynamic fan setting based on the target_pwm value in jtop but again the actual fan speed does not change.
  • The fan RPM never fluctuate
  • my temps are around 23-25 deg C all the time in MAXN power profile
  • after turning the system off, the FAN stays on - this was a behavior also with the Noctua fan.

So I tried putting it into another PC as a “system fan” and from BIOS I was able to change its speed …

Any help is welcome at this point …

hello peter.smitka,

may I know which JetPack release you’re working with?
starting with r32.4 release, it’ll maximize platform performance and fan speed by running $ sudo /usr/bin/jetson_clocks --fan. this --fan options will set the maximum PWM fan speed.

furthermore, it’s using hardware monitor, you may check /sys/devices/pwm-fan/hwmon/hwmon1/ for reference,
there’s look-up table for the PWM and fan RPM settings, please examine your cur_pwm configurations.
for example,

$ cat pwm_rpm_table
(Index, RPM, PWM, RRU, RRD)
(0, 0, 0, 40, 40)
(1, 1000, 80, 2, 2)
(2, 2000, 120, 1, 1)
(3, 3000, 160, 1, 1)
(4, 4000, 255, 1, 1)
(5, 5000, 255, 1, 1)
(6, 6000, 255, 1, 1)
(7, 7000, 255, 1, 1)
(8, 10000, 255, 1, 1)
(9, 11000, 255, 1, 1)

Hey and thanks for anwer. I’m using JetPack 4.6 - 32.6.1 the whole system is fresh installed and updated. I’m aware of the hwmon and cur_pwm and target_pwm settings as that is what also jtop modifies if set to manual.

My problem is that any change won’t actually propage in real life, so the the pwm fan will still run full tilt.

In any case, I have made modification to the setup by using an NON-PWM fan from noctua and adding an LDO to reduce voltage from 5V to 3.3V. Now the fan is super silent and I’m not bothered anymore.

There is an additional question though. I understand that the GPIO pins 5/3.3V are constantly powered if there is adapter plugged in. However, the PWM Fan port exhibits the same behavior. This means that after “shutdown -h” the system stops but the fan is still on until I unplug the system from mains.

This is true with the PWM or non-PWM fan and I could not find any reference why this is the case. Is there a setting? Is there something missing on the board?

hello peter.smitka,

FYI, we cannot reproduce the same failure on the Nano DevKits.
are you using a developer kit or it’s a customize platform?

It’s a standard devkit. I saw once this issue here: PWM Fan Is there a missing pull down resistor on pin4 of J15 on the B01 reference design?

I have not tried any resistors nor do I know which pins, but I would be interested if this is the case. I have the same unit - 4GB version B01.

you may also check GPIO_PE7 pin status while shutting down the device.

Can you be more specific please? What is the desired outcome of this action? What am I looking for when monitoring the GPIO-PE7?


hello peter.smitka,

the idea is checking from the software point-of-view, it’s the signal to control fan pwm, it should be disabled if powering off the target.
you may track /sys/devices/pwm-fan/cur_pwm values when shutdown the devices.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.