Jetson Nano PWM jetson-io.py problem

Hello

I am trying to use pin32 for Pwm. I tried to configure it using the jetson-io.py, however on startup i first get this crash report:

and when i try to run:
sudo /opt/nvidia/jetson-io/jetson-io.py
i get this error output:
File “/usr/lib/python3.6/curses/init.py”, line 78, in wrapper
cbreak()
_curses.error: cbreak() returned ERR

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File “/opt/nvidia/jetson-io/jetson-io.py”, line 594, in
curses.wrapper(JetsonIO)
File “/usr/lib/python3.6/curses/init.py”, line 100, in wrapper
nocbreak()
_curses.error: nocbreak() returned ERR

I tried to make sense of that from another thread which had trouble configuring the SPI pins, however i could make sense of that.

The jetson nano has an eemc memory, but an external SD card is used. I read somewhere that resetting the jetson fixed the problem, however i dont want to reflash the jetson, as i need Opencv with cuda and this takes multiple hours to install.

Any help would be much appreciated
Best regards

Hi Jetn_Felix,

Are you using the devkit or custom board for Jetson Nano?
What’s your Jetpack version in use?

For the devkit, there should be either eMMC module or SD Module.
Are you using the custom carrier board?

Hi Kevin

Yes we are using a waveshare jetson nano with eMMC. However we use an external SD card atm for more sapce.

After some reading i gave up trying to configure the GPIO pins with Jetson-Io. We reset our device once and now we are able to get into the Jetson-IO configuration page, however it just shows the CSI lanes. No 40Pin header.

After that we bought 2nd Jetson Nano with SD card only. However after first Login an error message on the top right appeard: Overcurrent Error Limiting performance. (or something like this) Then it crashed and now is compleatly bricked. No Boot, no usb output nothing. The Sdkmanager is also not working correctly when the special pin is bridged to get the Jetson into recovery mode. I confirmed the Jetson itself is faulty, because i swapped the boards with the 1st jetson i bought.

I will post this in a seperate thread, however please give any advice on how to configure the PWM on pin32 on emmc.

Thanks a lot

Since you are using the custom carrier board for Jetson Nano, you could not use Jetson-IO to configure your board (i.e. Jetson-IO is used for the devkit only).
You could write the pinmux register or use the pinmux spreadsheet to configure the pin for PWM.

Do you want to configure the following pin for PWM?


Yes exactly. Pin32 (PWM0) how would i do that?

Is this custom carrier board designed by you?
If so, please refer to the following instruction to configure the pinmux.
NVIDIA Jetson Linux Developer Guide : Jetson Module Adaptation and Bring-Up | NVIDIA Docs
You could simply select the column of “Customer Usage” from GPIO3_PV.00 to PM3_PWM.

Please also share the result of the following command on your board.

$ sudo cat /sys/kernel/debug/tegra_pinctrl_reg|grep pwm

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.