Jetson Nano Python3 GPS Problem

I have installed a GPS device at the serial Port
sudo cat /dev/ttyTHS1 shows a data stream. So device is ok.

The GPS demon was already installed on the SD card and is running.
(sudo apt-get install gpsd gpsd-clients would install it)

The app gpsmon is running, but shows no satellite data.

Now I tried to use it in Python3.

The import line:
from gps import *
does not find gps.
Is there anything not configured?
What may be wrong?
Thank you in advance,
Best regards,

Maybe below reference help on it.

1 Like

Thank you.
I know the tutorial.
According to this site
I have to edit gpsd
sudo gedit /etc/default/gpsd
But my jetson nano has no /etc/default/gpsd
I can not find the file.

I think, gpsmon does not work, because /dev/ttyTHS1 is not configured in this file.
The second problem is that from gps import * does not work.

Have a try below for import issue.

1 Like

Thank you for the link and for your support.
Now it works.
1)The demon was not running correctly. I uninstalled / installed GPSD and the demon.
2) It works only with Python2.7,not with Python3.
But in the web I found Libs for gps3.
Best regards,