Jetson nano reboot whenever streaming csi camera

Hello everyone! Recently I ran into the problem that my jetson nano got rebooted after execute video-viewer csi://0 or gst-launch-1.0 nvarguscamerasrc sensor-id=1 ! ‘video/x-raw(memory:NVMM),format=NV12’ ! nvvidconv ! xvimagesink sync=false command. (Yesterday everything is normal ). What should I do?
This is screenshot from jetson nano

Try ssh instead of VNC. Or connect HDMI display to check.

export DISPLAY=:0
gst-launch-1.0 .....

Dear ShaneCCC this is message from jetson

Have check with v4l2-ctl command to check if HW or connect problem.

v4l2-ctl --stream-mmap --stream-count=100 --set-ctrl bypass_mode=0 -d /dev/video0

Dear ShaneCCC jetson don’t give any feedback

Looks like can’t capture successfully from sensor. Suppose the cable or HW problem.

Dear ShaneCCC! How should I fix it?

Reconnect the camera to try or if you have others module to replace to try.

I just bought a new cable and I ran the gst-launch command it responded with a new message

Could you reboot and try nvgstcapture-1.0 also what’s the gst command?

this gst-launch-1.0 nvarguscamerasrc sensor-id=1 ! ‘video/x-raw(memory:NVMM),format=NV12’ ! nvvidconv ! xvimagesink sync=false

Both sensor-id 0/1 have the same problem?


What’s the BSP version? Could you try latest release.

Dear ShaneCCC
is this latest release ?

Check the version by cat /etc/nv_tegra_release

Dear ShaneCCC ! Here it is

Could you confirm if v4l2-ctl working for both video0 and video1.

Dear ShaneCCC Here it is!
(* notes I bought 2 camera sensor so I tested for 2 slot at the same time)

I mean

v4l2-ctl --stream-mmap --stream-count=100 --set-ctrl bypass_mode=0 -d /dev/videoX