Jetson NANO sd-card image download

Hi,

I’m trying to download the Jetson NANO image from the link provided at this page: https://developer.nvidia.com/embedded/learn/get-started-jetson-nano-devkit#write

Every time I try, using browser or wget, at some point around 25% the download fails. Here’s what I’m getting with wget when it fails:

--2019-04-03 16:43:33--  (try: 2)  https://developer.download.nvidia.com/assets/embedded/secure/tools/files/jetson-nano-sd-card-image/r32.1-2019-03-18/jetson-nano-sd-r32.1-2019-03-18.zip?vea7kfJLqXFU9NgCb3DQjDIxAkCMhJZlFKRK-jq1n9shzgXAd1xMq8efYmSpjPxnnT56mOhFhEzPbuuHwriD_umbLj4rbudLqZnBOf6hhdEtg_LPaNpmwtME3lBSwM2hDnVE-mDqDWv1NT6dSQQ8FiiAFM7UsNngFQ4usngRUQHyPMrwCHcTniC2CsdjvjBb3D3UXHbBgDWVFYt4GKAHs_1yf0x_LEztmqe1lnLrztk
Connecting to developer.download.nvidia.com (developer.download.nvidia.com)|192.229.221.58|:443... connected.
HTTP request sent, awaiting response... 206 Partial Content
Length: 5638005084 (5,2G), 5585186270 (5,2G) remaining [application/zip]
Saving to: ‘jetson.zip’

jetson.zip                                             4%[+===>                                                                                                                 ] 247,43M  2,56MB/s    eta 35m 21s
jetson.zip                                             4%[+===>                                                                                                                 ] 247,96M  2,55MB/s    eta 35m 21s
jetson.zip                                            22%[+========================>                                                                                            ]   1,16G  2,25MB/s    in 8m 17s  

2019-04-03 17:06:51 (2,28 MB/s) - Read error at byte 1243338682/5638005084 (Success). Retrying.

--2019-04-03 17:06:53--  (try: 3)  https://developer.download.nvidia.com/assets/embedded/secure/tools/files/jetson-nano-sd-card-image/r32.1-2019-03-18/jetson-nano-sd-r32.1-2019-03-18.zip?vea7kfJLqXFU9NgCb3DQjDIxAkCMhJZlFKRK-jq1n9shzgXAd1xMq8efYmSpjPxnnT56mOhFhEzPbuuHwriD_umbLj4rbudLqZnBOf6hhdEtg_LPaNpmwtME3lBSwM2hDnVE-mDqDWv1NT6dSQQ8FiiAFM7UsNngFQ4usngRUQHyPMrwCHcTniC2CsdjvjBb3D3UXHbBgDWVFYt4GKAHs_1yf0x_LEztmqe1lnLrztk
Connecting to developer.download.nvidia.com (developer.download.nvidia.com)|192.229.221.58|:443... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: http://developer.download.nvidia.com/403.html [following]
--2019-04-03 17:06:53--  http://developer.download.nvidia.com/403.html
Connecting to developer.download.nvidia.com (developer.download.nvidia.com)|192.229.221.58|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 252 [text/html]
Saving to: ‘jetson.zip’

jetson.zip                                           100%[=====================================================================================================================>]     252  --.-KB/s    in 0s

Is there some other way or place from where I could get the image?

Hi alexandru7ac9a, which region are you attempting to download the image from? I just re-downloaded it from here without an issue.

To get you started awhile, here is another link to the image (jetson-nano-sd-r32.1-2019-03-18.zip) that I uploaded:

https://nvidia.box.com/shared/static/dp7xma0f4jbvttha6xo14km14fztal7o.zip

Thank you dusty_nv, I was able to grab the image you uploaded at
https://nvidia.box.com/shared/static/dp7xma0f4jbvttha6xo14km14fztal7o.zip.

Best regards

I just received Jetson Nano and guess what, I can’t download the fella either. Stops around the 1G area. I’m using the zip location. Hmmm… not very encouraging. If you don’t hear from me, I was successful.

We’ve refreshed the CDN cache for this file, so let us know if you continue having problems downloading it from NVIDIA.com please.

I tried this morning around 8 hours ago using Mozilla and Chrome and its still not working for me.
Just started Safari browser download now

OK, thanks for letting us know. We made some changes to the server that hopefully should help - can you try again and say how it works for you?

https://developer.nvidia.com/embedded/dlc/jetson-nano-dev-kit-sd-card-image

had some trouble downloading the image too. I was able to download via wget -c but the image isn’t booting. It shows the nvidia logo and it shuts down right after (green led goes off). Here’s the sha/md5.

shasum jetson-nano-sd-r32.1-2019-03-18.img
419c8938df1d6df69346411572a95c7a1cad8101 jetson-nano-sd-r32.1-2019-03-18.img

MD5 (jetson-nano-sd-r32.1-2019-03-18.img) = 3113868ec147d9e23805d7bd6a22b3f5

please help, thanks!

Martin

Ok, I’ve downloaded the .img from the source provided. The md5 match with the previous, so it must be my power supply, I’m using a regular USB 3.0 output from a desktop computer, no I guess that’s not enough.

Hi ggmartins, a PC’s USB port does not supply enough power, so the board is probably shutting down from that. Please see here for recommended power supplies: https://devtalk.nvidia.com/default/topic/1048640/jetson-nano/power-supply-considerations-for-jetson-nano-developer-kit/

FYI, I am having problems downloading as well, but the box.com link seems to work ok.

5 hrs to down from chrome in win10 no stream occurs. https://nvidia.box.com/shared/static/dp7xma0f4jbvttha6xo14km14fztal7o.zip link is working so far halfway there. 2hrs needed to download.

I’m not able to download a correct image to windows. The download is named
‘jetson-nano-sd-card-image-r32.2.1.zip’
from http://developer.download.nvidia.com
The resulting download has has a size of 1084 Bytes (!) and a
md5-hash of fa05b38e84db21c5966953b7f371cf91 which is not the correct one.
Download from Germany.

Hi manfrhahn

here is the link available:

https://developer.download.nvidia.com/embedded/L4T/r32-2-1_Release_v1.0/Jetson-Nano-SDCard-Image/jetson-nano-sd-r32.2.1.zip?J5m_f9GF6-fgRsiZ9QSuKQHOg94pgcLq994qMVrgEpMr52SWq1oE1ikPSrZiwncHeuGnZJNzCpuntD26_-dndJhm_FgCSQkwQPuHDwt92pP6c_zQt4_eFuUGDlLWpLwi4PkjMecADO3rHqloh-qqU6EgObfToZnyXKB3X9y8Lue_powThKD0ylgEKmud9iJeITBLlg

Thanks manfrhahn and MilesW - we’re aware of the issue and are working to get it resolved ASAP. For now, you can use the direct link from MilesW.

MilesW’s download link worked - the file is much larger ;-) and the md5 checksum is the same as on the download page. Thank you!

Hello,

I just downloaded the file with MilesW’s download link. But when using the etcher, I still get an error message, that something might be wrong with the image.

Can you provide another link for the download?
The download gets aborted and when I try to continue the download, I guess the file is corrupted then.

Thanks

The link DID work for me, the file is definitly correct. In the meantime I finished the whole setup process. I think you can check the file health with the md5 checksum. You find the correct checksum in the ‘jetson download center’.
In my opinion you have problem with your internet connection that cannot be solved from nvidia. But maybe I’m wrong.

And you can try it from the download page now. The link has been repaired (its another filename now ‘jetson-nano-sd-r32.2.1.zip’).

Hi all, the issue with the Nano image should be fixed now - can you retry and let us know if you still have problems downloading? Thanks.