Jetson nano SDMMC3 voltage level

We require to set the SDMMC3 voltage level at 1v8 , so we added only -1-8-v property in device tree (under sdhci@700b0400 node).
Now we are observing around 2.4V for 600 milli seconds in both clock and data lines, then it sets back to 1v8. We have confirmed its after u-boot , but while kernel loading, now how can we always hold these lines at 1v8 . Thank you

Could you give the device tree configure.


yes here is the device node update in our device tree:

    sdhci@700b0400 { /* SDMMC3 for SD card */

            status = "okay";
            mmc-ocr-mask = <3>;
            uhs-mask = <0x0>;
            tap-delay = <3>;
            bus-width = <4>;
            /delete-property/ nvidia,en-periodic-calib;

gentle reminder

Are you talking about you see a 2.4v before uboot?

no, we are observing after uboot. From what is mentioned in jetson nano product product design guide , “Once POWER_EN is driven active (high), the module begins to Power-ON. When the module Power-ON sequence has completed, the SYS_RESET* signal is released”. Is it possible to hold the voltage at 1v8 for clock data and command lines(sdmmc_clk,cmd,data lines) from the power up itself.

Why the power sequence of the module is related to the sdmmc3 voltage?

What is the exact use case? Do you have device on sdmmc3 or not?

Sorry for the confusion,
We have connected an external emmc in sdmmc3 . With our device tree changes, EMMC is working fine without any errors.
But while doing our DVT, we observed 2.2V in Data and command lines for around 800ms while loading the kernel and after that, it changed to 1.8V and stayed so. So we need to fix this signal level to 1.8V permenantly.
Hope our requirement is clear and how can we set this voltage level to 1.8V permanently.

Thank you.

gentle reminder , currently we did a change in tegra210-porg-power-tree-p3448-0000-a00.dtsi -

                            max77620_ldo6: ldo6 {
                                    regulator-name = "vddio-sdmmc3-ap";
                                    maxim,active-fps-source = <MAX77620_FPS_SRC_NONE>;
                                    maxim,active-fps-power-up-slot = <0>;
                                    maxim,active-fps-power-down-slot = <7>;
                                    regulator-min-microvolt = <1800000>;
                                    regulator-max-microvolt = <1800000>;
                                    regulator-enable-ramp-delay = <36>;
                                    regulator-disable-ramp-delay = <674>;
                                    regulator-ramp-delay = <100000>;
                                    regulator-ramp-delay-scale = <200>;

We adjusted the max regulator voltage from 3v3 to 1v8 , now only for 200 Us we are observing spike to 2v2, is there something we did which we missed , that could help resolve this.
Thank you.

Hi, @ShaneCCC @WayneWWW any update on this.

Is this still an issue to support? Any result can be shared? Thanks

Yes you can go ahead and close it , was able to resolve it after changing prod settings , please refer to Jetson nano error in sdhci lines
.Thank you for the help.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.