Jetson nano shows nvidia logo 2 times for few seconds and then shuts down display

Hallo,

i have my Jetson Nano for few days and can not boot it. I thought my power supply was not good enough so i invested into a new one and now it also does not boot. It shows me 2 times the nvidia logo and afterwards shuts down the display. The green led which signals if power is supplied is shining green all the time. Even after the display is shut down it shines. Pleas can you help me, it makes me really frustrated.

Best Regards

Hi salim.tekin,

Problem seems related to the power quality, can you let us know which peripherals you have plugged into your USB ports?
Which Micro-USB power adapter are you using? You may want to see this thread with the recommended one.

You can also refer to below thread to see if can help on resolving your problem:
https://devtalk.nvidia.com/default/topic/1049782/jetson-nano/jetson-nano-not-booting/

Thanks

Hi kayccc,

i am using the barrel jacket with a Leike 5V/4A power supply (https://www.amazon.de/gp/product/B01HRR9GY4/ref=ppx_yo_dt_b_asin_title_o00_s00?ie=UTF8&psc=1). I am sure that the power supply is enough to power the Jetson Nano. To describe the situation further, the LED stays on all the time, even after the display is off.

Thanks

I am seeing something similar in that the Green LED stays lit and all I get is the NVIDIA Splash Screen and that is as far as it goes. I’ve tried a 5v 3A Barrel Jack power supply and multiple 5v 2.5 Amp USB power supplies all with the same result.

I’ve seen a similar thing on my system, it’s because my 4K monitor is not supported. Try plugging a 1080p TV or monitor into using HDMI and see if that boots.

@salim.tekin My German may be a little off, but this appears to say that the jack is 5.5mm OD x 2.5mm ID. The jack on the Nano should be 5…5mm x 2.1mm ID. That could lead to issues in your connection.

Yeah, different HDMI cable and different monitor and the same results; Green LED is lit and only the NVIDIA Splash Screen is seen when the board is powered.

Just to clarify, are these the suggested power supplies that are listed in the Users Guide?
https://www.adafruit.com/product/1995

https://www.adafruit.com/product/1466

I could not search for them by the part number provided but from the pics on Adafruit, these seem to match.

So, I had a bit of success with getting the Nano booted. I placed the SD card I used to burn the JetPack image to back into the Ubuntu PC I am using and there were some errors reported. Note, I used Etcher to burn the image on to a 32Gb uSD card.

This is what was seen in dmesg.

[ 3480.214799] usb-storage 2-4.4:1.0: USB Mass Storage device detected
[ 3480.214986] scsi host7: usb-storage 2-4.4:1.0
[ 3481.245848] scsi 7:0:0:0: Direct-Access     Mass     Storage Device   1.00 PQ: 0 ANSI: 0 CCS
[ 3481.246297] sd 7:0:0:0: Attached scsi generic sg4 type 0
[ 3481.496082] sd 7:0:0:0: [sdd] 62521344 512-byte logical blocks: (32.0 GB/29.8 GiB)
[ 3481.496698] sd 7:0:0:0: [sdd] Write Protect is off
[ 3481.496702] sd 7:0:0:0: [sdd] Mode Sense: 03 00 00 00
[ 3481.497336] sd 7:0:0:0: [sdd] No Caching mode page found
[ 3481.497342] sd 7:0:0:0: [sdd] Assuming drive cache: write through
[ 3481.506470] GPT:Primary header thinks Alt. header is not at the end of the disk.
[ 3481.506473] GPT:25165823 != 62521343
[ 3481.506474] GPT:Alternate GPT header not at the end of the disk.
[ 3481.506476] GPT:25165823 != 62521343
[ 3481.506476] GPT: Use GNU Parted to correct GPT errors.
[ 3481.506500]  sdd: sdd1 sdd2 sdd3 sdd4 sdd5 sdd6 sdd7 sdd8 sdd9 sdd10 sdd11 sdd12

So, I tried burning the image again but that resulted in the same issue.

Looking at the device with fdisk, I seen this issue.

sudo fdisk /dev/sdd

Welcome to fdisk (util-linux 2.27.1).
Changes will remain in memory only, until you decide to write them.
Be careful before using the write command.

GPT PMBR size mismatch (25165823 != 62521343) will be corrected by w(rite).
GPT PMBR size mismatch (25165823 != 62521343) will be corrected by w(rite).

Command (m for help): q

I then opened gparted and it reported there was unused space on the uSD card and if I wanted to let it allocate it; I said yes. So, there is now an unallocated partition.

I then placed this back into the Jetson Nano and it booted without issue.

I had read somewhere that if the uSD card was larger than 16Gb, the Nano will automatically resize the image to fit the uSD card. Is it possible that this process was taking place in the background? Previously I did leave the Nano running at the Splash Screen for at least an hour or so and it did not show any change. Should I have waited longer?

Sorry for the extended post.

Hi, jonnymovo, salim.tekin

There are some advice hope could help.

  1. on your ubuntu PC try to clean the partition table of your SDCard. sudo dd if=/dev/zero of=/dev/sdx bs=1024 count=1024
  2. Try to flash the image with Etcher on windows. Pls do not format the sdcard when there are some pop-up windows. After verification unplug the sdcard safely and try again with Nano dev kit.

Hi at all,

in my opinion this is no problem because my razor mouse and keyboard back-lit are shining, too. If i boot with my mouse and keyboard or without is makes no differenz while booting.

I formated my sd card (https://www.amazon.de/SanDisk-Extreme-microSDXC-Speicherkarte-SD-Adapter/dp/B07FCMBLV6/ref=sr_1_3?__mk_de_DE=ÅMÅŽÕÑ&keywords=sandisk+extreme+64+gb&qid=1554984988&s=gateway&sr=8-3) a few times also with the sd card formatter from sd assciation (https://www.sdcard.org/downloads/formatter/index.html) and flashed it with the balenaEtcher(https://www.balena.io/etcher/) a few times on different windows distributions (7, 10) with no difference.

One time, i am not sure what i did, i got into an error menu while booting but i had no keyboard stuck in so i could not choose any options.

I think my board is broken. Can i send it back and get a new one?

best regards
salim.tekin

Uh, thanks for the advice, however I have done this process many times (maybe close to 100++) for other Linux based boards such as Raspberry Pi, BeagleBone (Black, Blue, Pocket), Pine64 and others and have never run into this issue. I am not sure what is special with the JetPack image and/or the Jetson Nano, but I do have a solution so I will stick with that. I’m not interested in using Windows for the SD card burn.

Thanks,

Jon

Can you tell me what you did? Is it a problem with flashing the image into sd card?

best regards

I reflashed the SD card using Etcher on Ubuntu and when it was done I opened GParted which reported something about the device was not fully utilized so I clicked OK to let it allocate the rest of the space on the SD card.
Then I closed the program and put the SD card back into the Jetson Nano and it booted without issue.

That is pretty much all I did.

Also, I am powering the board via the barrel jack using a 5v 3a power adapter.

I flahed a dozen times now, with different programms but no difference. My flashed SD Card have 12 partions and allocates 11,99GB of 64GB(59,89GB) and 48,79 GB is unallocated.

The checksums of my image (jetson-nano-sd-r32.1-2019-03-18) are:
MD5: a7747b443e76c474236b695bbec2896f
SHA1: 10112a8ef107b5690ee0182b8b3ded2f3d19ddf1
SHA256: 4506a26fb2036f60216747c8517e8ae5cd51039311b5b509d70d5d00dc414875

How can i return the Jetson Nano? I would like a another one. This one is defective.

Best regards

For a 64GB uSD card or larger you need to format the card as ExFAT.
I am not sure if it is posted anywhere on the NVIDIA site, but this link does indicate this.

See the following
https://www.stereolabs.com/blog/getting-started-with-jetson-nano/

I tried it out but no difference. I also bought a plug for my power supply(https://www.amazon.de/weiblich-Ladegerät-Gleichstrom-Anschluss-DC-Hohlstecker-S-0128E/dp/B074XDYZRL/ref=sr_1_3?__mk_de_DE=ÅMÅŽÕÑ&crid=265LPXT04R2MR&keywords=dc+weiblich+stecker+2%2C1&qid=1555446972&s=gateway&sprefix=DC+weiblich+%2Caps%2C156&sr=8-3) to convert the barrel from 5,5mm x 2,5mm to 5,5mm x 2,1mmm but with no difference.

Can device boot up now?

The device did not boot. I my opinion it is defect so i am sending it back and i will buy another one.

Have you tried a different power supply or a USB power adapter?

If you have an 3.3v FTDI to USB cable, you could try connecting this to the Serial Port Header at J44 (just ensure the pinout is correct) and see if there is any console data being sent to this port that might point to the issue.
With the Nano I am not sure if this would require adding something to the bootup sequence to enable the console UART.

I was able to boot the device, set it up, and run couple of test codes with a 2.4A 5V USB

BUT today, after running $ sudo apt update, the Jetpack has started crashing on boot.

  1. Green light comes on the board,
  2. Splash screen on monitor
  3. Initial boot sequence showing several lines of [OK]…
  4. Screen goes blank trying to load GUI
  5. And then immediately the green light goes off