Jetson nano spi doesn't work

Hello there.
Even though I did everything in this forum still I couldn’t use my spi properly. When I connect pin19(mosi) to an oscillator I can’t observe any change. I tried to change device tree and everything but none of them helped me.

In another forum i have read that in /sys/kernel/debug/tegra_gpio, CNF column in row C must be 00 in order to map spi but I cannot change that it is still 1f. Maybe changing that would work but I have no idea how to change it. I tried to follow instructions in this link Jetson/TX1 SPI - , but there is no ./ file in my device. Can it be a solution?

Which Jetpack release you are using? If you use SDKManager to flash TX1, you shall see in the downloaded package. The default path is


Hi, DaneLLL. I use jetpack 4.5.1 and there is no folder “~/nvidia” in my device.

The image is downloaded to host PC. Please check the path on your host.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.