Jetson Nano ssh connection timeout error

HI i have 2 jetson nano (jetapck 4.5.1)
and i can run “ssh user@ip” on my desktop (ubuntu18.04) and it worked so i can access all of jetson nano i got
but reversely i can’t access to my desktop (ubuntu18.04) on my jetson nano both of them don’t work well saying “connection timeout”
i also did ufw settings, port setting includes port fowarding on my WI-FI (iptime) but it didn’t work…
Can someone let me know how to fix this problem?
when i run "ping " on the desktop
just one ping my desktop received no more…

Perhaps your PC is not set to allow outside ssh access. Many PC Linux installations default to this. Keep in mind that the ufw might control not only forwarding, but also the particular port (port 22 TCP). The sshd daemon might also be set to not accept certain connections. A connection timeout indicates that there was a route to host, and the network was not rejected, but the host did not provide a service on that port (or the service is denied). If it turns out that your forwarding is correct, then it implies sshd is not running or configured to not accept incoming connections; if it turns out that forwarding is wrong, then the ssh connection is failing because it isn’t the computer you expected to be the host.

For one thing, try a traceroute to the host from the Jetson, and try a traceroute from the Jetson to the PC. Post the result. It might indicate a forwarding issue or a simple “forwarding works, but ssh is not reacting” issue.

1 Like

Oh… sorry due to english is not my mother languages i did mistakes
Hi linuxdev i can access my pc form two of jetson nano
but reversely i can’t accesse form pc to nano saying timeout errors
i did ufw, port fowarding
and when i did pint form desktop to nano
there is just one ping but from nano to desktop the ping is work well in every secs
sorry for my fault can you let me know how to access jetson nano from desktop? as already i said i did ufw, fort fowarding… i spents 2days to solve this problem but i failed (even putty didn’t work)

I also connect my jetson to hostop(my smart phone)
at that time also i type ping@my_jetson_ip
but only one ping…no more jetson nano can’t get

Language differences can be worked around, but it does mean there might be mistakes.

Can you describe the network setup wiring topology? Examples:

Jetson->WiFi->Router With WiFi->wired to PC
# Or:
Jetson->wired to Router->wired to PC
# Or:
Jetson->wired to Router->WiFi of Router->WiFi of PC

The above are just examples. A diagram will be more descriptive than a purely language description.

Also, on both host PC and Jetson include what you see from these commands:

ifconfig
route
systemctl status ssh.service

Note: In many cases port forwarding won’t matter. Forwarding only matters if you want to reach the outside world by an intermediate computer. For the two computers to reach each other directly forwarding probably is not needed.

1 Like
pnltoen@pnltoen:~$ ifconfig enp3s0: flags=4163 mtu 1500 inet 117.17.251.58 netmask 255.255.255.0 broadcast 117.17.251.255 inet6 fe80::2f10:c3e9:84dc:2567 prefixlen 64 scopeid 0x20 ether 04:92:26:bf:d8:ad txqueuelen 1000 (Ethernet) RX packets 41309 bytes 46919602 (46.9 MB) RX errors 0 dropped 0 overruns 0 frame 0 TX packets 29475 bytes 2756153 (2.7 MB) TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10
loop txqueuelen 1000 (Local Loopback)
RX packets 34635 bytes 15319032 (15.3 MB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 34635 bytes 15319032 (15.3 MB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

pnltoen@pnltoen:~$ route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
default _gateway 0.0.0.0 UG 100 0 0 enp3s0
117.17.251.0 0.0.0.0 255.255.255.0 U 100 0 0 enp3s0
link-local 0.0.0.0 255.255.0.0 U 1000 0 0 enp3s0

● ssh.service - OpenBSD Secure Shell server
Loaded: loaded (/lib/systemd/system/ssh.service; enabled; vendor preset: enab
Active: active (running) since Fri 2021-10-29 07:08:49 KST; 8h left
Process: 1434 ExecReload=/bin/kill -HUP $MAINPID (code=exited, status=0/SUCCES
Process: 1430 ExecReload=/usr/sbin/sshd -t (code=exited, status=0/SUCCESS)
Process: 1107 ExecStartPre=/usr/sbin/sshd -t (code=exited, status=0/SUCCESS)
Main PID: 1126 (sshd)
Tasks: 1 (limit: 4915)
CGroup: /system.slice/ssh.service
└─1126 /usr/sbin/sshd -D

10월 29 07:08:51 pnltoen systemd[1]: Reloading OpenBSD Secure Shell server.
10월 29 07:08:51 pnltoen sshd[1126]: Received SIGHUP; restarting.
10월 29 07:08:51 pnltoen systemd[1]: Reloaded OpenBSD Secure Shell server.
10월 29 07:08:51 pnltoen sshd[1126]: Server listening on 0.0.0.0 port 22.
10월 29 07:08:51 pnltoen sshd[1126]: Server listening on :: port 22.
10월 29 07:08:51 pnltoen systemd[1]: Reloading OpenBSD Secure Shell server.
10월 29 07:08:51 pnltoen sshd[1126]: Received SIGHUP; restarting.
10월 29 07:08:51 pnltoen systemd[1]: Reloaded OpenBSD Secure Shell server.
10월 29 07:08:51 pnltoen sshd[1126]: Server listening on 0.0.0.0 port 22.
10월 29 07:08:51 pnltoen sshd[1126]: Server listening on :: port 22.

<Jetson Nano (Jetpack 4.5.1)>
kobuk@kobuksun:~$ ifconfig
eth0: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
ether 00:04:4b:ec:ad:05 txqueuelen 1000 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
device interrupt 150 base 0xe000

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10
loop txqueuelen 1 (Local Loopback)
RX packets 759 bytes 57877 (57.8 KB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 759 bytes 57877 (57.8 KB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

rndis0: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
ether 62:19:72:50:90:19 txqueuelen 1000 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

usb0: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
ether 62:19:72:50:90:1b txqueuelen 1000 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 192.168.0.11 netmask 255.255.255.0 broadcast 192.168.0.255
inet6 fe80::762e:2706:8f39:efd5 prefixlen 64 scopeid 0x20
ether 70:cf:49:9c:d7:09 txqueuelen 1000 (Ethernet)
RX packets 7580 bytes 9517575 (9.5 MB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 3132 bytes 478009 (478.0 KB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

kobuk@kobuksun:~$ route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
default _gateway 0.0.0.0 UG 600 0 0 wlan0
link-local 0.0.0.0 255.255.0.0 U 1000 0 0 wlan0
192.168.0.0 0.0.0.0 255.255.255.0 U 600 0 0 wlan0

kobuk@kobuksun:~$ systemctl status ssh.service
● ssh.service - OpenBSD Secure Shell server
Loaded: loaded (/lib/systemd/system/ssh.service; enabled; vendor preset: enab
Active: active (running) since Tue 2021-10-26 17:40:02 KST; 2 days ago
Process: 6309 ExecReload=/bin/kill -HUP $MAINPID (code=exited, status=0/SUCCES
Process: 6304 ExecReload=/usr/sbin/sshd -t (code=exited, status=0/SUCCESS)
Process: 4571 ExecStartPre=/usr/sbin/sshd -t (code=exited, status=0/SUCCESS)
Main PID: 4784 (sshd)
Tasks: 1 (limit: 4172)
CGroup: /system.slice/ssh.service
└─4784 /usr/sbin/sshd -D

10월 26 17:40:13 kobuksun systemd[1]: Reloading OpenBSD Secure Shell server.
10월 26 17:40:13 kobuksun sshd[4784]: Received SIGHUP; restarting.
10월 26 17:40:13 kobuksun systemd[1]: Reloaded OpenBSD Secure Shell server.
10월 26 17:40:13 kobuksun sshd[4784]: Server listening on 0.0.0.0 port 22.
10월 26 17:40:13 kobuksun sshd[4784]: Server listening on :: port 22.
10월 26 17:40:13 kobuksun systemd[1]: Reloading OpenBSD Secure Shell server.
10월 26 17:40:14 kobuksun sshd[4784]: Received SIGHUP; restarting.
10월 26 17:40:14 kobuksun systemd[1]: Reloaded OpenBSD Secure Shell server.
10월 26 17:40:14 kobuksun sshd[4784]: Server listening on 0.0.0.0 port 22.
10월 26 17:40:14 kobuksun sshd[4784]: Server listening on :: port 22.
lines 1-21/21 (END)

i am really sorry about my fault
First replay (my desktop, pnltoen), and second reply (my jetson, kobuk)

Jetson → Router with WiFI-> Router ← wired to PC

i am university student so to run jetson on my computer i have to fix the desktop ip
and also i installed Router with Wifi under the main Router as like above.
Can i ask about these systems (Jetson → Router with WiFI-> Router ← wired to PC) they connected each other in local server but can it ocuur problems to run ssh?

Thanks.

Is the first ifconfig and other output posted from the host PC? I am assuming so, and that the second post is from the Jetson in what follows.

Looks like the host PC works correctly on wired. I see activity and no report of issues. The host uses IP address if the 117.x.x.x range.

Looks like the Jetson works correctly, but only uses WiFi (which matches your description). Issues here won’t be due to any particular setup on the Jetson itself. However, the Jetson is using the network range of 192.x.x.x. This does not match the PC. Not always a problem, but it can be.

From the Jetson, can you ping the 117.x.x.x address of the PC? From the PC, can you ping the 192.x.x.x address of the Jetson?

If you can ping, then are you using the same address as the ping when you ssh?

Is this a high end router? Some routers might have firewall options the basic consumer router does not have. Sometimes higher end routers might require a setup to pass across the different subnets…basically the router is what bridges across the two subnets.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.