Jetson Nano stopped working after sudo apt get dist-upgrade, reflashing the image file didn't help

Hello everybody,

i tried to use the command sudo apt get dist-upgrade on my Jetson Nano 2GB, after that, the System told me to restart.
After the restart, the Jetson Nano kept stuck at the Nvidia Logo. I tried reflashing my SD-card and even tried different SD-cards but nothing worked.

My question now: Has anyone had a similar problem and knows a solution?
Does the Jetson Nano have something like a Flash-Memory (EEPROM) that cancels the boot?
If it has a Flash-Memory (not sure if that’s the right name), how do i delete it?

My english skills might not be the best.
Thanks for every helping answer.

hello prmg72pxvs,

may I know which JetPack release you’re working with,
could you please share the complete steps to reproduce the issue for reference,
thanks

hello JerryChang,

The image which worked at the beginning was Jetpack Version 4.5.0, after the sudo apt get dist-upgrade, the system told me to restart, after that it kept being stuck at the nvidia logo. For formatting I used SD Card Formatter. With balenaEtcher I tried reflashing my sd card with the newest version which is Jetpack 4.5.1 (2gb version). It kept being stuck at the nvidia logo. I tried Jetpack 4.5.0 and 4.5.1 several times. The serial interface is working, reads the sd card and recognizes linux. The boot-log is attached upon.
Thanks in advance for the help!

Boot_Err_2.txt (22.8 KB)

hello prmg72pxvs,

## Flattened Device Tree blob at 83100000<\r><\n>
   Booting using the fdt blob at 0x83100000<\r><\n>
ERROR: reserving fdt memory region failed 

according to the error logs,
may I know where did you load the device tree blob.
did you have FDT entry in the /boot/extlinux/extlinux.conf, please have a try to remove that for testing,
thanks

hello JerryChang,

Could you please explain that more explicite, its hard for me to understand this.
How should I remove this ? remove it from the Image on the SD card?
thanks!

hello prmg72pxvs,

could you please check the content of the configuration file, /boot/extlinux/extlinux.conf.
thanks

Some tips:

  • You can edit “/boot/extlinux/extlinux.conf” from either the SD card with the partition mounted on a host PC with Linux, or while it is running on the Jetson itself.
  • The file “/boot/extlinux/extlinux.conf” is plain text, and easily read by humans.
  • extlinux.conf normally uses the format of a key/value pair with space delimiter. For example, if you see this, then it specifies a device tree ("something.dtb") by file location (in “/boot”):
    FDT /boot/something.dtb
  • There are often two possible sources of naming the device tree (the “.dtb” file): Either in a partition, or else as a file in “/boot”. The “FDT /boot/something.dtb” is an example of naming by file. If that entry is missing, then the partition is used. Simply removing that FDT line will cause the partition version to be the one found; simply adding the FDT line causes the partition to be ignored, and the file to be used. You can pick which one is searched for by having the FDT entry or by not having it. There is no need to eliminate any actual .dtb file in “/boot”, it is just that entry within extlinux.conf which chooses.
  • If no “FDT” entry is in extlinux.conf, then you’ll always use the partition version.