Jetson Nano stuck in recovery mode after removing and reconnecting power supply

I was doing a project with their AD-3DSMARTCAM1-PRZ, which uses an NVIDIA Jetson Nano SoM with eMMC, product number P3448-0002. There is a custom image at ADI and I was flashing the camera with that one, until one fateful afternoon, when the camera decided not to boot anymore. I suspect that it is in recovery mode, because in dmesg I see “APX” instead of “Linux Tegra” for Product.

I determined, that the problem is with the SoM (when I used a SoM in the camera, about which I knew for sure, that it worked, everything was fine).

I tried flashing the device again with ./ (this is used by ADI) and I noticed that immediately after the flash I can connect to the SoM with picocom, because a ttyACM0 appears in /dev. I tryed flashing the device with sdkmanager from the docker image provided here for ubuntu 18, using the following command:

$ sudo docker run -it --privileged -v /dev/bus/usb:/dev/bus/usb/ -v /dev:/dev -v /media/$USER:/media/nvidia:slave --network host sdkmanager:18 --cli install --logintype devzone --product Jetson --version 4.6.4 --targetos Linux --target JETSON_NANO_TARGETS --flash all --additionalsdk 'DeepStream 6.0.1' --staylogin true

The result was similar, I could connect to the SoM via SSH. However, in both cases, after I disconnected the power and I connected it back again, the original error occurred.

I suspect, there might have happened something during the times when I flashed the camera, because I flashed it several times. I am not entirely sure though, that it is a hardware problem or something that I can solve by meddling with some files or registers in Linux, right after flash. If it is a hardware problem, do you know whether it can be repaired or is it just better to buy a new SoM?

Hi matyasdaniel004,

It seems you are using a custom carrier board for Jetson Nano.

What’s your Jetpack version in use?

For the screenshot you shared, it seems not in force recovery state.

Are you using the custom BSP package provided from your vendor?
Please share the full command you used to flash the board.

Please share the full serial console log when you do this test.

That is right.

It is JetPack 4.5.1.

Yes. I asked around, and most probably the kernel and the devicetree are compiled differently.
The command which flashes the SoM is:

$ echo -q password | sudo ./ -r jetson-nano-emmc mmcblk0p1

I don’t know how to do that. As I said, the device is presumably in recovery mode, for which I think I have further evidence: the sdkmanager sees the device as if it is in recovery mode.

I can send you some packets that I captured with wireshark on bus 1, device 12, which corresponds to the Nvidia device, but they don’t really say more than the dmesg entry.

The method to dump serial console is posted all over this forum if you look into more posts.

This method is for NV devkit. We don’t know if your custom board has it or not. If you are not the board vendor, contact the board vendor for the method.

Also, recovery mode is a pure hardware event. If you are sure the device cannot leave recovery mode, you could contact with the board vendor about it too.

If you see APX, then most likely your host PC is a VM. You would not normally see APX, but it isn’t because of the module, it is instead related to host PC.

I see APX, but my host PC is not a VM. It is an Ubuntu 22.04, and as I mentioned in the post, immediately after flashing, I see Linux Tegra.

I work for the carrier vendor, but I don’t think the problem is with the carrier. My latest tests were on the Jetson Nano Dev Kit, but I had the same issue.

Could your cross check with other jetson modules (if you have any)?

I used the ADI carrier with the exposed UART pins. Since the device was in a kind of recovery state, I did not have to force it to flash the image. After the flash, because there were no hardware connections forcing the SoM into recovery, the module booted up. I could connect to it via /dev/ttyACM0. Then, I removed the power supply, and connected it back, but the device was no longer responding.

In the text file below you can see the debug messages corresponding to the flashing of camera and the booting. When I removed the power supply and connected it back, there were no more debug messages
jetson_log.txt (124.2 KB)

I did that. Other Jetson modules are working fine with the same carrier.

Then I think you may need to RMA that module.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.