Jetson Nano TDM slave mode no longer work with L4T 4.6

Hello,

I had a system running on L4T 4.3 where the Jetson Nano was clock slave to an external TDM device. After updating to 4.6, the Jetson Nano will not use the signals coming from the external TDM device. No data at all, not even messed up data.

Was there a change introduced for the TDM/I2S interface in a later version of L4T?

Here are the settings I’m using.
NOTE: These are the same settings for L4T 4.3 as I’m using with L4T 4.6

alsactl init tegrasndt210ref
amixer -c tegrasndt210ref -q sset ‘ADMAIF1 Mux’ I2S4
amixer -c tegrasndt210ref -q sset ‘I2S4 codec frame mode’ dsp-b
amixer -c tegrasndt210ref -q sset ‘I2S4 fsync width’ 1
amixer -c tegrasndt210ref -q sset ‘ADMAIF1 Channels’ 16
amixer -c tegrasndt210ref -q sset ‘I2S4 Channels’ 16
amixer -c tegrasndt210ref -q sset ‘I2S4 Sample Rate’ 48000
amixer -c tegrasndt210ref -q sset ‘I2S4 codec bit format’ 32
amixer -c tegrasndt210ref -q sset ‘I2S4 input bit format’ 32
amixer -c tegrasndt210ref -q sset ‘I2S4 codec master mode’ cbm-cfm
amixer -c tegrasndt210ref -q cset name=“I2S4 Loopback” off

Thank you!

Hi,

“No signal” could be due to wrong pinmux settings. There is a change in the way Pinmux is set for 40pin header pins with JP4.6.

Please refer this section for further details regarding 40pin Header usage/pinmux settings (and here).

Kindly refer to troubleshooting section if above doesn’t help.

Thanks,
Sharad

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.