Jetson nano tensorflow 2.4.0

i have installed jetpack v 4.5.1
and i installed tensorflow from
with all needed dependencies
i just tried a small test:

import numpy as np
import tensorflow as tf

D = tf.convert_to_tensor(np.array([[1., 2., 3.], [-3., -7., -1.], [0., 5., -2.]]))
and this stops with 
tensorflow/core/kernels/linalg/] Non-OK-status: GpuLaunchKernel( DeterminantFromPivotedLUKernel<Scalar, false>, config.block_count, config.thread_per_block, 0,, config.virtual_thread_count, n,, pivots, nullptr, status: Internal: too many resources requested for launch

i tried several things, for days now, and always the same error: GpuLaunchKernel  status: Internal: too many resources requested for launch

is there a workaround or a other tensorflow version


This is a known issue and we are still checking this.

Is TensorFlow 1…15.x acceptable for you?
If yes, please give it a try.


thanks for the quick response
i’ll give tf1 a try, but i have to reprogram all my codes and models
so is there a plan when this issue with tf2 will be fixed, or when a working release of tf2 is released



We can reproduce this issue in our environment.
And it’s checking the details with our internal team.

Will share more information with you later.