Jetson Nano Terminal Issue and Power switching modes issue

when i am trying to install some packages …suddenly terminal is not opening and also power switching modes also not showing at the right corner of home screen.

There are some other possibilities for access:

  • Try CTRL-ALT-F3 to see if it gets to a text-only terminal (if it does, then you should be able to get back to the GUI with CTRL-ALT-F1 or some other CTRL-ALT-F#, where # is somewhere from 1 to 7…usually it is 1, but it can sometimes be a different number). You could then post the output of the log command “dmesg”.
  • A remote system might be able to log in with ssh for access to logs. You could then post the output of the log command “dmesg”.
  • Serial console is by far the best tool, and you can save a boot log which probably has the error listed and also boot information even before Linux loads.

Do you have access through any of those methods?

Yeah i will try and update…

I have a one more doubt please clarify …I have jetson Agx xavier which is having same issues but what i did is i used rm rf -users command to format/remove all files…but rightnow the board is not even booting and screen is blinking… how to solve the issue…i am new to use this boards so requesting you kindly explain step by step.

What was the exact rm command? Which directory did you recursively delete? Many directories cannot be removed without complete destruction of the operating system, but I’m not sure what the “-users” is (if you are having trouble with the forum interpreting characters as markup you can precede the character by a backslash “\”, or perhaps mark it as “code”. There are very few software installs which require manual file addition/removal, but there are some.

rm -rf /usr directory this is the command we have used to remove all installed files in the jetson board…but right now it is not even booting and Nvidia home screen also not showing. Requesting you kindly help me out.


Such terrible situation, I would suggest you directly flash your board with sdkmanager…

There isn’t much help for that other than reinstalling the operating system. You could clone first to save other content, but removing “/usr” is removing most of the operating system. There is no chance of it functioning without that.

Note: Use the package manager system, either “dpkg” or “apt” to remove installed content. But beware this can also remove content which would destroy the operating system if the wrong package is removed.

Yeah but i don’t have problem with content in the jetson board…i just need it should work properly. As I have mentioned the booting screen is blinking when I switched on power supply. i couldn’t move any further option/screen. i tried with SDK manager for flash but it is not completing 100%…many times I tried to flash …it is coming up to 99% then it stopped there only…even I waited 2 hrs for completing 99 to 100%. So I request you kindly tell the procedure what have to do.

Is the host PC a normal Ubuntu 18.04 computer? Is it a VM? Either way, when it gets stuck, maybe try to unplug and replug the USB cable once you are certain it is stuck.

yes it is 18.04 version …i tried all things multiple times but it stuck 99% only

it is ubuntu 18.04 laptop not VM

Is the cable used for flash from the dev kit? I’m thinking that possibly this might fail if it is just a charger cable, but for the most part, this should work. I’m running out of ideas on why it would consistently fail at this point of flash.

yeah i am using cable from dev kit …that’s what I am facing don’t the problem why it is stopping at 99% only I tried many ways but no use.


Are you able to share the log from sdkmanager? There is an export button on GUI, you can use that to export log. (312.1 KB)

kindly check

today also i tried again it stopped at 99% (234.6 KB)

same again it stopped at 99% even i checked with cable everything…i have doubt can we format everything like new board?


Just notice some weird point here. What is the exact platform we are talking about here?

The topic said you are using “Jetson Nano” and one comment said you also have a “Jetson AGX”, but your log only has a record that you are flashing “Jetson NX”.