Jetson Nano + TFT LCD 480x240 screen connexion through HDMI decoder issue

Hi there,

we are trying to connect an LCD screen Kyocera 55931 (480x240) to a Jetson Nano (Jetpack 4.6) through an Adafruit TFP401A HDMI-to-DVI decoder board with a modified EDID configuration, the Xorg log and syslog seems to accept this configuration however nothing displays on the screen. Not the xrandr is seeing a screen to be used ?

Below some of the logs/config files used.

Regards.

[ 9.539] (II) NVIDIA(GPU-0): — Building ModePool for IGR ADAFRUIT 43 (DFP-0) —
[ 9.539] (II) NVIDIA(GPU-0): Validating Mode “480x280_128”:
[ 9.539] (II) NVIDIA(GPU-0): Mode Sources: EDID, Detailed
[ 9.539] (II) NVIDIA(GPU-0): 480 x 280 @ 128 Hz
[ 9.539] (II) NVIDIA(GPU-0): Pixel Clock : 25.00 MHz
[ 9.539] (II) NVIDIA(GPU-0): HRes, HSyncStart : 480, 488
[ 9.539] (II) NVIDIA(GPU-0): HSyncEnd, HTotal : 493, 576
[ 9.539] (II) NVIDIA(GPU-0): VRes, VSyncStart : 280, 284
[ 9.539] (II) NVIDIA(GPU-0): VSyncEnd, VTotal : 294, 340
[ 9.539] (II) NVIDIA(GPU-0): H/V Polarity : -/-
[ 9.539] (II) NVIDIA(GPU-0): Mode “480x280_128” is valid.

[ 9.538] (–) NVIDIA(0): Valid display device(s) on GPU-0 at SoC
[ 9.538] (–) NVIDIA(0): DFP-0
[ 9.538] (–) NVIDIA(0): DFP-1
[ 9.538] (II) NVIDIA(0): NVIDIA GPU NVIDIA Tegra X1 (nvgpu) (GM20B) at SoC (GPU-0)
[ 9.538] (–) NVIDIA(0): Memory: 4057700 kBytes
[ 9.538] (–) NVIDIA(0): VideoBIOS:
[ 9.538] (–) NVIDIA(GPU-0): IGR ADAFRUIT 43 (DFP-0): connected
[ 9.538] (–) NVIDIA(GPU-0): IGR ADAFRUIT 43 (DFP-0): External TMDS
[ 9.538] (–) NVIDIA(GPU-0): IGR ADAFRUIT 43 (DFP-0) Name Aliases:
[ 9.538] (–) NVIDIA(GPU-0): DFP
[ 9.538] (–) NVIDIA(GPU-0): DFP-0
[ 9.538] (–) NVIDIA(GPU-0): DPY-0
[ 9.538] (–) NVIDIA(GPU-0): HDMI-0
[ 9.539] (–) NVIDIA(GPU-0): DPY-EDID-8d89a177-ac79-0d6a-362f-3259d867f451
[ 9.539] (–) NVIDIA(GPU-0): HDMI-0

cat /sys/kernel/debug/tegradc.0/edid
00 ff ff ff ff ff ff 00 24 f2 34 12 d2 04 00 00
02 20 01 03 81 28 14 78 8a a5 8e a6 54 4a 9c 26
12 45 46 00 00 00 01 01 01 01 01 01 01 01 01 01
01 01 01 01 01 01 c4 09 e0 60 10 18 3c 10 08 05
4a 00 5f 36 00 00 00 18 00 00 00 fc 00 41 44 41
46 52 55 49 54 20 34 33 20 20 00 00 00 10 00 00
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 10
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 51
xorg.conf

Section “Module”
Disable “dri”
SubSection “extmod”
Option “omit xfree86-dga”
EndSubSection
EndSection
Section “Device”
Identifier “Tegra0”
Driver “nvidia”
Option “AllowEmptyInitialConfiguration” “true”
Option “ModeDebug”
Option “moreVerboseModeValidation” “true”
EndSection
Section “Monitor”
Identifier “Monitor0”
VendorName “Monitor Vendor”
ModelName “Monitor Model”
Modeline “480x280_161.00” 4.75 480 496 536 592 272 275 285 288 -hsync +vsync
EndSection

KYOCERA_ T-55931GD018HU-T-ANN(55931ANe-_STD).PDF (533.5 KB)