Jetson Nano unable to open Serial over USB to Arduino Uno


I had the Jetson connected directly with the Arduino via USB cable and all worked well. After several communication iterations (Jetson->Arduino communication only), opening the serial port in python failed and I am unable to connect to the Arduino anymore (not via the studio as well). Tried different Arduino/Cable with no help.
Here is the error:
Traceback (most recent call last):
File “/home/dlinano/.local/lib/python3.6/site-packages/serial/”, line 322, in open
self.fd =, os.O_RDWR | os.O_NOCTTY | os.O_NONBLOCK)
PermissionError: [Errno 13] Permission denied: ‘/dev/ttyS0’

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File “”, line 3, in
with serial.Serial(‘/dev/ttyS0’, 9600, timeout=10) as ser:
File “/home/dlinano/.local/lib/python3.6/site-packages/serial/”, line 244, in init
File “/home/dlinano/.local/lib/python3.6/site-packages/serial/”, line 325, in open
raise SerialException(msg.errno, “could not open port {}: {}”.format(self._port, msg))
serial.serialutil.SerialException: [Errno 13] could not open port /dev/ttyS0: [Errno 13] Permission denied: ‘/dev/ttyS0’

There is constraint in Jetson Nano. Please check this:
Nano ttyTHS1 receive data lost - #21 by DaneLLL

For receiver, please run in higher baud rate and give it a try.

Ok. Will try thanks!
Though it does not explain why it worked and then lost connection without renewing all of a sudden.

I burned a new JetPack on another SD and managed to communicate with the Arduino though the device appeared as ‘/dev/ttyUSB0’. Had to follow a guideline by NVIDIA of adding the user to some group to have access to the device for writing permission. But seems to work now.
Will revert to changing BAUD rate if it breaks again. Thanks!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.