Jetson Nano vs Raspberry Pi UART Settings

I’m currently attempting to control a BasicMicro RoboClaw motor controller using my Jetson Nano over UART communications talking to a bus of individually addressed motor controllers using packet serial. Using one isn’t a problem, but once you add more to the packet serial bus it starts sending packets super slow and it leads to erratic motor control. I’ve gotten it working with a bunch chained together on Raspberry Pi using this tutorial: https://resources.basicmicro.com/packet-serial-bus-operation-with-the-raspberry-pi-3/

I’m really struggling to figure out why it won’t work on the Jetson Nano, there were some settings that needed to be configured on the Pi to do this, but I haven’t found a way to do so on the Jetson, if it’s even necessary: https://resources.basicmicro.com/configuring-the-raspberry-pi-3-serial-port/

Anyone got any ideas? Thanks a ton

You can run

to get a list of your serial port settings on your Raspberry Pi while your BasicMicro RoboClaws are connected and functioning. Then you can use stty on your Jetson Nano to create the same port settings. Hopefully that’ll work.

I can’t answer, but some information which might be useful is that the steps on the RPi were related to disabling the serial console in order to make the serial UART available for general use. If you were to use a serial UART on the Nano which has a serial port running on it, then this would be required; however, if you used an unused serial UART, then this would not be needed.

On the A02 revision carrier board J44 has a 3.3V TTL level serial UART which is normally set up as a serial console. B01 seems to have something similar on J50. I don’t know about other board revisions.

Note also that for speeds above 115200 you will need two stop bits instead of one.

You might check this document and see which revision you have, and mention which serial UART you are using:
https://developer.download.nvidia.com/assets/embedded/secure/jetson/Nano/docs/NV_Jetson_Nano_Developer_Kit_User_Guide.pdf?rDl5U0t9QfeGZmi9DiQO46QFSMMmoGS9SWJwTSGPYH_jivOQOgY_FqEBQyfY3Otx2RwR9xZ5VR7QrEcl7xKGbqF5FoTgOV3bzZpxKS2_bZL5zY_Bfj42QZRzo-h4cxz7CsN-suGD6CfMYi53UmHsMosSerRfox-CyzpJHNhAaPWAiy8JJIgZYvqawZaXV4TCfAQ

Once you know the UART is not being used by serial console you can use the steps given by @oseberg related to port settings.