Jetson nano wifi

Thanks Fei, can you post the ouput of “lsmod” so we can see which driver you are using instead?

We have been doing some testing with this patch: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1365844

Would be interesting to try your method as well.

1 Like

here it is:

fei@fei-desktop:~/sandbox/test/lib/python3.6/site-packages/Adafruit_GPIO$ lsmod
Module                  Size  Used by
bnep                   16562  2
fuse                  103841  5
rtl8xxxu              115372  0
mac80211              719792  1 rtl8xxxu
cfg80211              589351  1 mac80211
nvs                    54527  0
nvgpu                1555053  100
bluedroid_pm           13912  0
ip_tables              19441  0
x_tables               28951  1 ip_tables

Thanks, it looks different from the patched 8192cu driver from my link above. Will have to try out your method next.

I was also noticing slow wifi speeds with the EW-7811UN.

Following the steps in the patch to install 8192cu driver seemed to work for me. I am not sure the simple blacklist of rtl8192cu worked for me. I tried that first and iwconfig showed:

wlan0 IEEE 802.11 ESSID:“Occamsrouter”
Mode:Managed Frequency:2.412 GHz Access Point: 2C:7E:81:F3:99:2E
Bit Rate=1 Mb/s Tx-Power=30 dBm
Retry short limit:7 RTS thr=2347 B Fragment thr:off
Power Management:off
Link Quality=54/70 Signal level=-56 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:7 Missed beacon:0

After installing the 8192cu patch:

wlan0 IEEE 802.11bgn ESSID:“Occamsrouter” Nickname:“WIFI@REALTEK
Mode:Managed Frequency:2.412 GHz Access Point: 2C:7E:81:F3:99:2E
Bit Rate:72.2 Mb/s Sensitivity:0/0
Retry:off RTS thr:off Fragment thr:off
Power Management:off
Link Quality=99/100 Signal level=87/100 Noise level=0/100
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

Bit rate seems to have jumped from 1 to 72 Mb/s. Thanks for the help.

I have seen the same behavior as Jonathan -

  • disabling the rtl8192cu driver (and using the rtl8xxxu driver instead) limited the bit rate to 1 Mb/s
  • installing the fixed 8192cu driver allowed me to connect with a stable connection at 72.2 Mb/s

The installation instructions for the fixed driver (GitHub - pvaret/rtl8192cu-fixes: Realtek 8192 chipset driver, ported to kernel 3.11.) disable both the native rtl8192cu and rtl8xxxu drivers - so if you are following the installation instructions, don’t skip that step if you’ve already disabled the rtl8192cu drivers using the instructions in the thread - you’ll probably end up using the rtl8xxxu driver rather than the fixed driver (this is a mistake that I made).

I just put the Nano on a shelf, seems I don’t have any USB WiFi devices that it likes, meanwhile they all work with a Raspberry PI… Come on, add a few of the common drivers please, I don’t have the time to spend compiling a new kernel nor should I have to. Yes a 8265 and antennas are in a slow truck somewhere… The USB wifi: lsmod r8188eu is seen as cfg80211 - I killed my hardwired network for a Verizon Hotspot
UPDATE: Late that evening the power went down and when it restarted I had WiFi, don’t know how but it worked, kind of slowly but working.
The Intel card and antennas arrived this morning, WAY better speed plus Bluetooth.

thank you. You save me a lot of time.!!

I think the driver for wifi dongle in the offical image should be replaced by this fix.

I am just wondering if nano/Xavier will work with Intel Wi-Fi 6 AX200
[url]https://www.intel.com/content/www/us/en/support/products/189347/network-and-i-o/wireless-networking/intel-wireless-products/intel-wi-fi-6-series/intel-wi-fi-6-ax200.html[/url]

Thanks

I had the same problem of intermittent connection using an rtl8192cu based wifi usb dongle. I did

echo "blacklist rtl8192cu" | sudo tee -a /etc/modprobe.d/blacklist.conf
echo options rtl8xxxu ht40_2g=1 dma_aggregation=1 | sudo tee /etc/modprobe.d/rtl8xxxu.conf

FInally rebooted.

After reboot the USB dongle has been working normally for 1hr.

Looking at the ‘Connection information’ in the wifi symbol in the right upper corner, I see the driver displayed is ‘rtl8xxxu’…

I also get

nvidia@nvidia-desktop:~$ lsusb
Bus 002 Device 002: ID 0bda:0411 Realtek Semiconductor Corp. 
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 046d:c534 Logitech, Inc. Unifying Receiver
Bus 001 Device 003: ID 0bda:8176 Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN Adapter
Bus 001 Device 002: ID 0bda:5411 Realtek Semiconductor Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
wlan0     IEEE 802.11  ESSID:"RIS_2G"  
          Mode:Managed  Frequency:2.457 GHz  Access Point: EC:08:6B:21:C1:A0   
          Bit Rate=1 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Power Management:off
          Link Quality=66/70  Signal level=-44 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:3467   Missed beacon:0

An internet speed shows 11Mbps download and 5Mbps upload, which is in accordance to another laptop I tested. I am not sure if I should follow the steps provided in (GitHub - pvaret/rtl8192cu-fixes: Realtek 8192 chipset driver, ported to kernel 3.11.)

Hi,

I have problems with the Edimax Wifi USB stick, too.

When I boot the Nano with only the micro USB (5V 2.5A Raspberry supply) connected, the Wifi doesn’t start.

It only starts, when I connect the LAN cable and log into Nano (via Ubuntu Desktop or SHH). After that the Nano connects to my Wifi network and I can SSH into it from remote to the wlan ip. Via ifconfig I then find two ip adresses (eth0 and wlan0).

I tried to set the “Turn off Wifi to save power” function to “off” in the Gnome Settings (from remote desktop connection), but when I reopen the settings window it is back to “on”.

I tried the terminal command: sudo iw dev wlan0 set power_save off

But when I plugged out the LAN cabel and reboot the Nano, I can`t find the Nano in my Wifi network.

Any ideas?

Best regards,
Lars

Hi Orandus, did you try this patch from the post above?

[url]https://devtalk.nvidia.com/default/topic/1049303/jetson-nano/jetson-nano-wifi-/post/5329699/#5329699[/url]

Hi dusty_nv,

yes, I did. lsmod says:

Module                  Size  Used by
rtl8xxxu              115372  0
mac80211              719792  1 rtl8xxxu
cfg80211              589351  1 mac80211
nvs                    54527  0
nvgpu                1555053  18
bluedroid_pm           13912  0
ip_tables              19441  0
x_tables               28951  1 ip_tables

Should I try the steps from GitHub - pvaret/rtl8192cu-fixes: Realtek 8192 chipset driver, ported to kernel 3.11.? The signal is ok, when Wifi is on, but my problem is, that it will not start after reboot, and that I have to log in via LAN cable…

ifconfig wlan0:

wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.23.199  netmask 255.255.255.0  broadcast 192.168.23.255
        inet6 2003:c1:4f4b:6b9c:a510:be38:fd6a:a6d2  prefixlen 64  scopeid 0x0<g                               lobal>
        inet6 fe80::144f:1cd3:ad1f:e335  prefixlen 64  scopeid 0x20<link>
        inet6 2003:c1:4f4b:6b9c:e89e:3ee:bd4d:a5db  prefixlen 64  scopeid 0x0<gl                               obal>
        ether 74:da:38:ee:41:80  txqueuelen 1000  (Ethernet)
        RX packets 1307  bytes 145830 (145.8 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 82  bytes 12736 (12.7 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Thanks for your help,
Lars

Sure, that can be worth trying - although it sounds like your issue is different from the others in this post. The original issue from this post was that the wifi disconnects after a period of time (not really related to reboot), but you could still try these patches to see if it helps. If the issue persists, I would recommend trying a fresh SD card image to see if it may be related to trying the multiple patches and configuration issues. You should be able to initially connect (even after reboots) with the vanilla driver - the symptom is it disconnects after a period of time.

Hi,

ok, I tried the fixed driver, too, but the problem is still the same. I will install the Nano completely new as you recommended.

Best regards,
Lars

Hi,

now it’s working!

I think there was something wrong with the first installation. The install process was very fast this time, last time, it hangs for 10 or 15 minutes at on step, but not so this time.

Perhaps it was helpful, that the Wifi dongle was sticked into the Nano, before I began with the installation…

Thanks for your help!
Lars

OK great, good to hear Lars. Now if you notice the wifi disconnecting after a period of time, you can try the patches from this thread. We hope to include that in the next JetPack for the Edimax adapters.

You are welcome.

I accident bought a ax200 m.2 network card for my jetson nano.
still waiting for a workable driver :(

SAD

any roadmap for implementing support of ax200 m.2?
Thanks

lspci
00:01.0 PCI bridge: NVIDIA Corporation Device 0fae (rev a1)
00:02.0 PCI bridge: NVIDIA Corporation Device 0faf (rev a1)
01:00.0 Network controller: Intel Corporation Device 2723 (rev 1a)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)

Attempt 1.

git clone https://git.kernel.org/pub/scm/linux/kernel/git/iwlwifi/backport-iwlwifi.git
make defconfig-iwlwifi-public
sed -i 's/CPTCFG_IWLMVM_VENDOR_CMDS=y/# CPTCFG_IWLMVM_VENDOR_CMDS is not set/' .config
make -j4
sudo make install
sudo make install
  Building modules, stage 2.
  MODPOST 6 modules
  INSTALL /home/nvidia/backport-iwlwifi/compat/compat.ko
  INSTALL /home/nvidia/backport-iwlwifi/drivers/net/wireless/intel/iwlwifi/iwlwifi.ko
  INSTALL /home/nvidia/backport-iwlwifi/drivers/net/wireless/intel/iwlwifi/mvm/iwlmvm.ko
  INSTALL /home/nvidia/backport-iwlwifi/drivers/net/wireless/intel/iwlwifi/xvt/iwlxvt.ko
  INSTALL /home/nvidia/backport-iwlwifi/net/mac80211/mac80211.ko
  INSTALL /home/nvidia/backport-iwlwifi/net/wireless/cfg80211.ko
  DEPMOD  4.9.140-tegra
depmod will prefer updates/ over kernel/ -- OK!
Note:

depmod will prefer updates/ over kernel/ -- OK!
Note:
You may or may not need to update your initramfs, you should if
any of the modules installed are part of your initramfs. To add
support for your distribution to do this automatically send a
patch against "update-initramfs.sh". If your distribution does not
require this send a patch with the '/usr/bin/lsb_release -i -s'
("Ubuntu") tag for your distribution to avoid this warning.

Your backported driver modules should be installed now.
Reboot.

rebooting

and nothing

modprobe iwlwifi
rfkill list
0: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no

Reference found networking - Locating Drivers for Intel AX200 Wireless on 5.1 Kernel - Unix & Linux Stack Exchange
en:users:drivers:iwlwifi:core_release [Linux Wireless]
AX200NGW implementation of driver support on nvidia jetson nano - Intel Communities

and bluetooth? how to add the bluetooth ?
I did not come up with anything better than to load the module with

modprobe  iwlwifi bt_coex_active=1

that doesn’t appear having bluetooth as well