Jetson nano's I2C

Hi, Jetson nano’s I2C dose not connect the ADS1115.

When I use the ‘i2cdetect -r -y 0’, it is Ok but library of ADS1115 is not operating.

I get error messages that " Could not determine default I2C bus for platform."

so i change the address to 0x40 bus failed and i get another error.

i2c_2

Help me.
Thanks.

library is here “GitHub - adafruit/Adafruit_Python_ADS1x15: Python code to use the ADS1015 and ADS1115 analog to digital converters with a Raspberry Pi or BeagleBone black.” (simplytest.py)

Can i2cget/i2cset utils worked?

Hi, @ShaneCCC. Thank your answer.

i2cget/i2cset is not worked.
i2cdetect -l don’t show ADS device.
ADS device is okay. i tried on arduino.

Are you using I2C on 40-pin header? Please refer to the 40-pin docs in DLC first:

https://developer.nvidia.com/jetson-nano-developer-kit-40-pin-expansion-header-gpio-usage-considerations-applications-note

Hi, @Trumany !

this file is not downloaded with “File Not Found or Link has Expired”.

Please search “40-pin” in DLC.

Thanks! @Trumany
You mean change the AR and AS of I2C(SDA and SCL). Is right?

There are two I2C ports on the 40-pin header, I2C0 and I2C1. Both are 3.3v voltage level. You should check your device to make sure which I2C is attached to and what the voltage level is.

I checked this document but no problem

I tried PCA8695. this module is available through I2C.

ADS1115 has pull up. Is this problem? (because i2c has pull up too.)

What’s the pull-up voltage level? There is 3.3v pull-up inside the module. Did you use a oscilloscope to observe the waveform of I2C data/clk to make sure the communication is correct?

@Trumany
Yes, i can get the waveform of I2C data/clk.
pull-up of ADS1115 is 3.3v (PCA9685 is 3.3v too.)
I2C works very Well. (i tried PCA 9685)
There is problem using ADS1115. (I tried ADS1115 on arduino, no prolem.)

Thanks a lot!
I solved!

Good news, can you tell how you solve it?