Jetson Network issues after Power failure

I have been working on Jetson Nano for development, and usually plug it out directly after my work. Last week when I resumed work after this, I had issues using internet on the Jetson. It couldn’t even ping 8.8.8.8. I tried whatever I could but wasn’t able to restore the access.
Then I re-flashed my device.
Today I was working on jetson, logged in via ssh using the hostname(jetnet). I left the device powered on, but no active application running. There was a power failure . Then as I resumed work, the hostname(jetnet) was not resolvable. although the router can see jetnet, and I tried setting the hostname again but no avail. I had to login using the Local IP address after the power failure.

Is it that Jetson is sensitive to hard boots/ powering off the power itself?

It is a Linux issues I think.
It’s recommended to shutdown before power core out.

The Jetson nano can boot, then check network configuration is ok or not.

Btw, a local login, running “ifconfig” (or “iwconfig” if purely Wi-Fi), might show the address changed. DHCP does not guarantee the same address after a reboot unless the router itself is bound to that IP address and MAC.