Jetson NX can't recognize Lidarlite V3

I’m trying to use the garmin lidarlite with the Jetson NX via i2c pins, however when I run the i2cdetect command it doesn’t recognize that any device is connected. I’ve tried on both i2c busses. After probing the connections with a multimeter, I found that the Jetson was only providing 1.2V of power to the device through the GPIO pins and 3.3V through the i2c pins, so I tried to swtich to an external power supply (arduino nano powered by usb cable). I now get 4.65V of power to the LidarLite and 5.3V from the i2c pins, however the Jetson still doesn’t recognize that anything is connected.

hello chealsie.bains,

according to Jetson Xavier NX Developer Kit User Guide , are you using J12, a 40-pin expansion header to connect the device?
you may also check NVIDIA Jetson Xavier NX GPIO Header Pinout - JetsonHacks for Jetson Xavier NX GPIO Header J12 PINOUT for reference,

1 Like

Yes I have attached an image with my wiring configuration:
white - 5V
black - GND
blue - SDA bus 1
green - SCL bus 1

hello chealsie.bains,

could you please execute Jetson-IO for Configuring Jetson Expansion Header.
there also a list of configuration for certain hardware modules you may check for reference,

I needed to add a ground reference from the Jetson to my power supply. Now it functions properly with an external 5V supply