Jetson NX won't boot i2c issue

Hello everyone,

I think I accidently changed eeprom via i2c 0x50 and 0x57, when I was trying to connect to distance laser sensor via i2c. And now my jetson doesn’t boot.

It says:
bad mac address at /chosen/nvidia,ether-mac: null.
ether-mac read from DT failed -99
error during i2c read probe (-121)

I read other topics with similar issues, and I think I need to reset my eeprom. How should I achieve this for Jetson NX, is there any tutorial ?


You should dump the log from serial console.

Thanks for the answer, but I do not have such cable. Maybe you have some tutorial to reset eeprom from jetson bash console ?

There is no such tutorial. If you cannot run i2cdump or i2cset in your current situation, then you better ordering a cable and sharing the log first.

Here is log attached.

log.txt (45.3 KB)

Tried to insert new sd card with freshly flashed image. Didn’t help, shows same exact errors.

please remove “quiet” inside the rootfs → /boot/extlinux/extlinux.conf. And dump log again.

This is just to enable log. Not a solution. You will still fail to boot aftet this step.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.