Jetson Orin does not power on when plugged in

I have a Jetson Orin and when I plug it in it does not power on at all. Is it dead? If not why is it doing this?

up until I rebooted it by unplugging it and plugging it back in it was turning on when I plugged it in.

Re-flash the devie with SDK Manager.

This is very dangerous.
Don’t do it.

It has a thing where it powered on automatically when plugged in. So i thought that was how i was supposed to do it.

I will avoid doing it in the future.

So for the topic at hand is it dead or is there a way to fix it?

Get the log:

Following the steps. for minicom I don’t have any ttyACM* stuff but i do have a bunch of tty* with numbers after them.

This /dev/ttyACM0 will only show up on your host PC when the power cable is plugged in.

power cable is plugged in. Its in the usb c port above the barrel port

Do you know you need to use the micro USB cable for getting log?
If you don’t know how all these stuff works, please just re-flash the device with SDK Manager.

I have a micro usb cable plugged into it and a ubuntu pc.

Please just do this.
https://docs.nvidia.com/sdk-manager/install-with-sdkm-jetson/index.html

I’ll give it a shot

I have it installed but it won’t let me use it as it says “user not authorized on NVIDIA developer server” I have an account created and it let me log in.

This is required:

registered, program updated to latest version. It says that it “could not detect a board”. Board has power and is connected via USBC (i also tried micro usb)

You need force recovery mode…

Looked up how to do it and tried it. It does not show in the sdk manager nor the lsusb.

I tried it connected via USB C and micro usb

Are you using the USB-C port in the front of the device?
Not the one anove DC jack.

the one above the dc jack for power the one in the front for connecting

Is it a real host PC instead of a VM?
Or maybe you didn’t even do it right when pressing buttons.

yes its a real pc

i did:

Press and hold the recovery button and then

case 1. If the board is not powered on state
Press/release the power on button. And release the recovery button.

case 2. If the board is powered on state
Press/release the reset button and release the recovery button.

recovery button is the middle. right is reset and left is power.

per the force recovery mode directions here