Jetson Orin long boot time by jp5.0.2

UEFI has waited about 90 seconds. Can this wait be removed? How to deal with it?

bootup log:
[2022/10/9 15:38:40] Jetson UEFI firmware (version 1.0-d7fb19b built on 2022-08-10T20:18:13-07:00)
[2022/10/9 15:38:40]

[2022/10/9 15:39:37]
[2022/10/9 15:40:09] ** WARNING: Test Key is used. **

Hi 305248199,

We only take within 10s.
Are you using default JetPack-5.0.2?

uefi bin is default JetPack-5.0.2

Hi, NVidia
I have a similar problem with new versions of Jetpack that always start very slowly

Please rebuild the UEFI from source and replace the original one with the debug build binary.

This will enable the full log in UEFI and please check which took your time in UEFI.

Build orin UEFI error

Here is a UEFI binary built by another user. You can directly try it.

Use uefi_ Jetson_ DEBUG. Nvidia orin cannot be started,
Log attached
2022-10-13_13_59_43.log (87.5 KB)

Ok then we still need to check your build problem first.

thank you!!!

uefi boot log
uefi.log (160.3 KB)

Is there any RGMII interface on your board? If not, disabling it from your device tree…

The delay from UEFI is because of the ethernet driver…

have RGMII interface.
is kernel dtsi to close ?

Yes. Disable the ethernet interface that is not in use.

tegra234-p3701-0004-p3737-0000.dtb modfity to
ethernet@2310000 {
status = “disabled”;

The problem is still the same…

Can the RGMII interface be closed in the UEFI source code, and if so, where?


There is also MGBE interface. Please also see if that one is enabled.

Also, what is your method to update device tree after you change it?

    ethernet@6810000 {

status = “disabled”;

the have to close

I think the key is the question here…

Also, what is your method to update device tree after you change it?

Replace /boot/dtb/kernel_ Segra234-p3701-0004-p3737-0000.dtb file