Jetson Orin Nano 8GB + Cuda - Driver Incompatibility

Hello together,

i was wondering if anyone can help me.
I am using a Jetson Orin Nano 8GB and have the issue that the newest Cuda-Jetson-Toolkit is not compatible with the Cuda-drivers on the Orin.
Toolkit: CUDA Toolkit 12.1 Update 1 Downloads | NVIDIA Developer

First installed the ubuntu 20.04 Version on the Orin which worked fine.

Downloaded the Cuda Compute Shader acceleration examples from the github repository:

Compiling is no problem and works without any error.
Running returns the following error:

“[Vector addition of 50000 elements]
Failed to allocate device vector A (error code CUDA driver version is insufficient for CUDA runtime version)!”

The code ‘runs’ successfully until memory on the Jetson GPU has to be allocated.

Ive also added all, as far as i know, required ENV variables to the ~/.bashrc:

‘nvcc --version’

nvcc: NVIDIA (R) Cuda compiler driver
Copyright (c) 2005-2023 NVIDIA Corporation
Built on Mon_Apr__3_17:19:26_PDT_2023
Cuda compilation tools, release 12.1, V12.1.105
Build cuda_12.1.r12.1/compiler.32688072_0





$PATH also contains the path to the cuda implementation

I did also uninstall and prune everything once and get a fresh clean install using “apt-get remove cuda” and removing the paths variables in bashrc and all other links to the toolkit.

Maybe someone here has had a similar issue.
Would be very thankful for any help.

You can use the SDK manager to install the CUDA via the JetPack.
Please follow the steps at Install Jetson Software with SDK Manager.

Use of SDK Manager to flash Jetson requires an x86 computer running Ubuntu 20.04.


Hello @kayccc ,

thanks alot for your reply. Is there no other way to do this ?

I have a Ubuntu 22.04 Server (Hardkernel N2P, or a Khadas Vim4) available. I can have access to a USB Port from any of those servers, but im not able to connect any of them to a display atm.

All Desktop machines are MacOS unfortunately.
I have though a x86 Intel Mac from 2018, where i can run a docker 20.04 ubuntu environment for instance.
I mean docker supports cross platform mountable usb drives so i could ‘pipe’ the usb just into the container…

I have tried at least everything i know of with apt, is there really no way it can be done using the apt-package manager ?

I will give an update, wether that maybe worked with the intel in a vm maybe
Thanks !

Found this Command-Line Install :: NVIDIA SDK Manager Documentation

Thanks alot!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.