Jetson Orin Nano Dev Kit serial connection error


I flashed my Jetson Orin Nano Dev kit with the newest config via SDK Manager. The configuration is as follows:

Ubuntu 20.04 focal
Jetpack 5.1.2
L4T 35.4.1
CUDA 11.4.315

When I connected an Arduino Mega to the board via 1 of 4 USB-A ports, the system detected the Arduino as at /dev/ttyACM0 port. I can successfully upload code to the Arduino board and communicate via the serial terminal. However, it worked for only one time after the physical connection was established. To make it work again, I have to remove the USB cable, wait for a while, and reconnect it again. I tried with the Jetson Xavier NX board, and Jetson Nano board but this behavior never happened. Any idea how can I solve this problem?

Hi luongquanghuan,

Is there any error log in kernel log?
Could you share the full dmesg for further check?

What do you mean about “one time”?
Does it work only for you to send/receive any message?

What’s your Jetpack version using for Xavier NX? also JP5.1.2?


I found this error from dmesg by running bellow command:

sudo dmesg | grep error

[ 9.895546] pva: probe of 16000000.pva0 failed with error -110
[ 9.909062] nvdla: probe of 15880000.nvdla0 failed with error -110
[ 9.922917] nvdla: probe of 158c0000.nvdla1 failed with error -110
[ 14.123238] EXT4-fs (nvme0n1p1): mounted filesystem with ordered data mode. Opts: errors=remount-ro,discard
[ 15.859269] imx219 9-0010: imx219_board_setup: error during i2c read probe (-121)
[ 15.914393] imx219: probe of 9-0010 failed with error -121
[ 15.951227] imx219 10-0010: imx219_board_setup: error during i2c read probe (-121)
[ 15.987728] imx219: probe of 10-0010 failed with error -121

What I mean by “one time” is after I closed the serial connection (keep the USB cable connected) and re-connect the serial connection again via the terminal, from this second time it won’t work.

As for Jetson Xavier NX, I used the same jetpack 5.1.2.

Thank you.

I think my problem is also related to this topic
Orin USB problem

L4T R35.4.1 should include the latest USB firmware.

The error message you shared seems not related to your USB/serial issue.
Could you share the full dmesg after you re-connect the serial connection failed?

How did you close and re-connect the serial connection?


Here is the dmesg file.
dmesg.txt (82.6 KB)
First I turned on Jetson Orin with an Arduino board attached. Then launch a ROS launch which includes a ROS serial_node (rosserial_python package) to communicate with the Arduino board. The first communication was successful. Then I closed the serial connection by killing the launch file (Ctrl-C) on the current terminal. Then re-connect the serial connection again by relaunching the ROS launch file at the same terminal. From this time, the serial connection won’t work.

How your application create the serial communication?

Have you tried to use UART interface on the devkit to communicate with your Arduino board?

How do you know it doesn’t work? Is there any error message?

Does this log include the failed part when you try to re-connect the serial?
It seems only 21s from boot up in this log.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.