Jetson Orin Nano kernel panic after successful SDK manager flash

Hi Team,

I have successfully flashed a new Jetson Orin Nano 8GB Development kit using SDK Manager from a native Ubuntu20 host, to Micro SD Card (128GB).

However, after the initial Nvidia splash screen, the display goes blank. Serial logs shows a kernel panic.

Can you please help in identifying the issue?. Attached all the logs.

flash_1-9_0_20230526-170746.log (41.5 KB) (405.2 KB)
uartLogs.txt (568.5 KB)

Experimented combinations, But still get same issue,

  1. Tried flashing from native Ubuntu18 host.
  2. Tried flashing SD card flash method by downloading and flashing with etcher



did you have any other storage devices attached to your Jetson Nano?
Looks like the SD card is treated as mmcblkp1, but the system attempted to mount rootfs on mmcblkp0 and failed.


Thanks for analysing the logs.

I haven’t connected any other storage devices.
Trying to flash and boot from SD card alone.



just want to make sure that, is SD card set as the top priority in UEFI boot menu?

Can you try to flash with another SD card? Or maybe format the SD card with a host PC and flash again. (as there seems to be some issues with the GPT table on the SD card) Your SD card is not detected by the system until it mounts initrd as rootfs, which is weird.

Thanks for the suggestions.

Experiment 1:

  1. Used SD card Formatter and formatted the 128 GB SD card I have been using and tried flashing from SDK Manager.
  2. Got same issue for 2 trials.
  3. I am unable to enter boot menu when this happens. Pressing escape key was not working.

Experiment 2:

  1. Tried flashing on another SD card (64 GB) and it worked straightaway.

Not sure why the other SD card was throwing such issues. Both are brand new SD cards of same manufacturer(Sandisk).

Thanks for the support. I will proceed with the new SD card.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.