Jetson Orin Nano not detected by Mac when connected via USB-C

I just got a new Jetson Orin Nano and was able to flash the sd card with Jetpack 5.1.1 and set it up with a static ip address as well as SSH into the Nano while it was connected via Ethernet. After installing several packages, I installed chromium browser and I rebooted the Nano which ended the SSH session. However, when I tried to SSH back in, I was not able to. I pinged the IP address and it said the host was not found even though I can see it connected to my network with the same IP address. I then tried connecting it to my Mac via the USB-C port like I did during the setup, however now my Mac isn’t detecting it as a USB device. What is going on and how can I fix this?

Of course this is not going to give you anything on a Mac.
Check the serial console log.

It was working like that before, that’s how I set it up. When I plugged it in I typed
ls /dev/cu.usbmodem* and that command showed the device

The console log also does not show the device. I tried this on a different laptop and that also was not able to detect the Jetson.

So you got nothing with screen or any other softwares capable of serial connection?

yes, that’s correct. I used “screen” in the initial set up, but now i’m getting nothing.

Then please re-flash the device.

ok, I will do that. Do you know what could have caused this problem so I can be careful in the future?

There’s no log so I cannot really tell.

Using a Mac as your host PC is also not really recommended.
Some error cannot be recovered by simply flashing the SD card image, and requires an Ubuntu PC to update the bootloader on the device.

Reflashing worked. Switched to Windows, thanks.